Rega p10 and PhoenixNet fuses

I put off the power wall cable which is connected to the powerblock.
I wanted to swap some cables. But I forgot to switch off my PhoenixNet switch and also the Rega P10 power supply.
Now they don’t work both.

Do someone know how to change the fuses of the Rega ps and of the PhoenixNet?

Can’t help you regards the Rega, the PhoenixNet fuse tray is below the power socket. If you head over to the Innuos site there is a short video on changing the fuse.
Good luck.

1 Like

Rega website shows the back of the power supply with a fuse holder between the power in and the XLR socket

Thanks guys, I found. I will put the two fuses off and go to an electrical shop to see if they have the same.

1 Like

I tested in an electrical shop the two fuses. Unfortunately they are not broken.
So I will have to send the PhoenixNet and the P10 ps to repair.
As I disconnected the wall power cord connected to the powerblock, without switching off the switch and the power supply, something bad happened to them.
Bad luck, as I recently got the new 250.
Fortunately I can still listen to music, putting an usb stick in the front of the Nds. It sounds quite similar to the Melco with PhoenixNet in UPNP mode. Quitte surprising. But from memory, so I will compare both when my switch will return.


Whenever I have used a USB drive in a Naim streamer, it has always sounded as good as anything streamed over the network. Sometimes it makes me think that we should all sell the servers and network stuff we accumulate and just buy a load of USB sticks. There might be enough cash left to fund a major upgrade.

1 Like

I have same misfortune twice with my Roon Nucleus. Once is my 250DR trip the main and unfortunately my Roon is on the same extension and it brick and refuse to operate.

I sent for repair. When back I put it on another extension different from my Wireworld. When my replacement 552 came I make sure to shutdown the Roon Nucleus from web UI first but I must have switch off the extension too quickly and I brick my Nucleus again.

I am not sure why Nucleus and your PhoenixNet can be so sensitive to shutdown process. Anyone can explain? Is it due to need to power drain first??

I would have hope equipment can be more robust to power plug accidentally pull off and not totally brick immediately.

FR - I’m assuming, since the fuses are intact, you’ve tried both units with different power cables, just to rule out an issue here ?

1 Like

I had the same idea. Had to try that this morning. And guess what? It’s the power cable!
What to do next? How to repair the power cable now?


Wow! That’s weird that the cable dies but not the fuse! FWIW I’ve not found the PhoenixNet to be more sensitive to power outages etc. than anything in my system. In other words, it’s always been rock solid.


That’s good. I don’t know your power setup, but as you mentioned a power block, are you sure all the outlets are working on there (are they individually fused for example ?).

Have you tried the power cables you think are not working directly into the wall socket - what cables are they out of interest ??

1 Like

I have also another question. On one speaker, there is like a radio frequency noise, strident. And another like pop pop. It’s very minor, but when there’s no music, I can hear this very little stridency from my sitting place. Can it have a bad effect on music? When music is at very low volume, if I go very close with my ear to the speaker, I can hear it .

Hi guys, it’s finally not that. When I unplugged those two cables, and used another powerblock, it works. So the problem is from the two power strips inside the powerblock.
Easy repairable @james_n ?

Now all is working. The REGA ps and the PhoenixNet are on a cheap powerblock. Much better news than before.


Does your power cable/plug/block have a fuse?

I had a similar pop noise on my system especially when I turned the fluorescent lights on.

I found it was from an unshielded power cable that was close to or touching the speaker cables.

Maybe the power cable you have used to test is cheap and without shielding.

Whereas the normal power cables that broke are more expensive and have shielding.

1 Like

Oh good. That’s saved you a bit more aggravation.

As @Yorkshireman says, is your power block fused in some way. Is it just those two outlets that don’t work or the whole block ?

If the whole block doesn’t work then check the cable supplying it and the socket it’s plugged in to.

1 Like

The 4 other sockets work. It’s an Eros Titan powerblock. I couldn’t see on the specs if there are fuses for each outlet.

I use high quality power cables. I tried today an XLR to RCA cable, a Rega cable. No noise at all, in any speaker.
However the drop in sound quality from the Chord signature tuned array XLR to XLR is important.

I tried to isolate cables, not touching themselves, and now it’s a bit better.
I hear the little noises only if my ear is very close to the speaker.
Do you think it’s a problem, does it affect sound quality ?


Speak to the manufacturer and see what they advise regarding the sockets that have stopped working.

Anyway, glad you are nearly all sorted :+1:


I meant the power cable you used to test the Phoenix Net and Rega. I thought it was maybe not as good as the ones that are broken.

It doesn’t for me but I only (used) to get the odd pop/crackle every so often but since moving unshielded power cable away from speaker cables I no longer have this problem.

1 Like

I suppose you use Schuko plugs at the wall in France? so there will be no fuse in the plugs.

1 Like