Roon stalling after 192k track in N272

Does anyone else have the above issue.

192k tracks from Qobuz play OK then stop as if not quite reaching end.
Whole 192k albums can be played successfully as well as individual consecutive tracks.
This happens in both playlist and Roon radio mode where it selects next track. A forward arrow press moves it to next track and carries on.
I am using ROCK on Nuc as source and using LMS2UPNP for Roon feed to N272
This only happens on N272 and not on DACV1 connected by USB to iMac.

I have not yet posted in Roon IIRC they are not interested in LMS / software workarounds

Any suggestions?

My guess is that lms2upnp has a bug in it or a bug in the way the Roon Rock sends data to the lms2upnp. Lms is quite stable running on a Rpi, however I found that if I mixed resolutions, i.e, one track was 16/44 and the next was 24/96, I always got stoppages there on my NDX. Never a problem playing an entire album of 16/44 or 24/96. I tried a Chromecast audio (CCA) via optical to the NDX and did not see this issue of stoppages, CCA is a Roon supported device.
Not exactly your problem, but likely related. You may want to check with the dev of lms2upnp.

Hi is there a reason to use the LMS over ropieee?

I don’t have this issue with lms-to-upnp and an NDS. I host lms in a docker container on a QNAP Nas.

Maybe post your config file for comparison?

I don’t have Qobuz but I do have Crime of the Century in 192hz. I’ve gotten through it with no stoppages with lms2upnp running on a Rpi 3. I added a CD quality rip to the end of the que while Crime was playing. As mentioned, doing this always stops playback for me at the bit rate transition. If I click “advance” the next track with a different bit rate will play.

Ropieee requires that you use a digital input (most of the time) on the 272/NDX/S and have a Raspberry pi available. Lms2upnp allows the 272/NDX/S to use its networked upnp method and it runs on several platforms.
I’ve used both methods and I’ve found for best compatibility using Roons RAAT protocol is the most effective and hassel free way to go, Ropieee is very good. I do like and use lms2upnp though even with the minor issues I’ve mentioned.

1 Like

It strikes me as a cludge if you have to get upnp involved and somewhat aginst the whole argument roon has for going with its own protocal.

I have a couple of pi running in the house with either usbdacs or a simple dac hat on the pi. You can configure ropiee to use the hats rather than USB out in the web interface

1 Like

I agree it is a software “kludge”, for best results use Roons protocol. I like to tinker and have the time to mess about.

Well, my one month of a Roon trial is up soon. I’ve tried three methods of using Roon to my NDX and one other method direct into my SN2.

Method 1: lms2upnp software running on Rpi 3 running Raspbian.
Stable running software with some minor issues with stoppages when mixing up bit rates in the que. It always stops for me when the bit rate changes, I click “Advance” to get it going. Not a big deal if you always just play full albums. If you are a play-list person, problems of stoppage will arise if different bit rates (in my experience for sure).

Method 2: Chromecast Audio (as a transport) via optical out to NDX. I had only one problem and that is a known issue when playing 24/96 or 24/88 - some stuttering (you can tell Roon to downsample to eliminate it). Since CCA is discontinued it’s not likely going to be fixed. No other issues and I am surprised at how good the little device worked and the sound I got out of my NDX. It was one of those products that was just too good for its price.

Method 3: GentooPlayer on Rpi3 (kind of like Ropieee), with an Allo DigiOne card and a BNC-BNC cable into my NDX. It was wired ethernet.
I had the Roon transport software running on it so I got the full Roon experience. It was a solid and stable system that worked very well. No full MQA, just the first unfold done by Roon Rock, it was just fine.

Method 4: Ropieee on a Rpi 3 using Wi-Fi with an Audioquest Cobalt USB Dac plugged into a USB slot on the Rpi 3. Sound output was via an Audioquest Evergreen 3.5 mm to RCA cable into the SN2.
I got the full Roon experience with this method using their RAAT protocol. I use Tidal so I was able to play an MQA album with first unfold on the Rock and final unfold on the Cobalt. I had no problems at all with stoppages, stuttering etc. I was shocked at the sound quality, very good to my ears (as good as the NDX?).

I am an Audirvana user but the Roon interface, app, and experience is a step up. I did not notice any better sound between the two though, and that was key to my decision to stick with Audirvana and with Audirvana, I don’t need anything to make it work, it uses UPNP direct to the NDX. Lots of time this past month to experiment.

1 Like

This is exactly what happens with me. I don’t have any issues with other bit rate changes either up or down.

Not a big problem to click advance. :slightly_smiling_face:

At least it is not just my setup

@garyi it is a bit of a cludge but works while waiting for 372 :unicorn:

Hi I have hopefully uploaded screen screenshot on config file. I have deleted some endpoints for brevity - all Sonos.

config xml screen shot|272x500

CK

Sorry for the delay in replying.

Here’s mine, there are some differences. It might be worth you taking a copy of yours, amending with my settings and seeing how it goes.

@trickydickie

Thanks for taking time to respond.
I made each of the amendments in turn but they didn’t result in any change in behaviour.
My response is a bit late in coming because I came unstuck when I tried to fix IP address of my Roon core, I reckoned that was the IP address in your ‘server’ definition. That was the only change I didn’t make.
I mistyped the address to one outside my network and couldn’t reconnect to the NUC. I had to reinstall Roon Rock fully to recover. Fortunately I did not lose anything and was able to restore 2 day old database backup, so a good test. :flushed:
Unfortunately the new installation of Roon Rock didn’t change the behaviour.
I might try running lms2upnp on Synology Nas or even RPi just to try.
I have even more time on my hands since golf courses are shut.
Again thanks for your help.

CK

Yes, that IP address is my Roon server.

I run lms-to-upnp within Logitech Media Server (LMS) itself. It was just easier that way.

I’ve successfully run LMS on a Netgear NAS (RN102) and now run on a QNAP but within a container (docker).

I don’t use any of LMS’s functionality and have removed all the other plugins. Works very reliably.

The only glitch when changing resolutions I see is a small cutoff of the beginning of a track. This happens even when playng via UPNP using the Naim app. My NDS does this and my previous NDX did too.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.