Seven Years with Uniti Core

Your post led me to check if the update was available for my Core too. Checking for updates revealed this:

It’s interesting that it reports the installed firmware version as version 0.

Checking ‘About’ shows the version is actually, but still no update is available. I wonder if the update is being released in a staged manner, such that it’s being made available to some users before others?

How very weird Clive…!

Have you tried doing a power off/on cycle with your Core – may just refresh its memory as to what firmware it’s using…!?

2.5.6 Update should probably be showing for most now, has been 24hrs, so should be enough time for global servers to populate through……I knew yesterday morning within minutes it had been released publicly, yet it didn’t show up on my system until overnight….but then, I’m at the arse end of the planet…! :rofl:


1 Like

Yes I would suggest a power off restart too. Also stop and restart your app.

1 Like

Actually yes, the App is the more obvious one…

I tried closing the app and restarting first since that’s a lot easier than turning the Core off, but that didn’t work. So I switched the Core off, which is always troublesome because I never know when to release the power button - should I wait for a click, for example? Anyway I unplugged it and after 30s plugged in and restarted and lo and behold the update was there. Now working fine on v. 2.5.6. Thanks for the tips, S.C. and David.

1 Like

Good stuff, glad you’re sorted now.

Yeah, if putting into Hibernate mode, I hold the power button until I hear the click, then release……I think the guidance is 10secs or so, but that never seems enough to me, though I think the click does happen after you release the button….but personally I prefer holding it until……It’s not something I like or aim to have to do too often…!
I’m sure David will know more re the official protocol….


You have described perfectly my anxiety regarding the Core’s power off process. I seem to recall once I held the power switch in for about a minute or so and there was more than one click. The instructions on line don’t really describe this adequately in my opinion.

I must say that I never had any anxiety about turning it off. I haven’t read the instructions for a while but I think you press for about three seconds or a bit more and let go. Probably something clicks (!) It should then vanish from the app, which means it is now in deep sleep. Then you can pull the power safely.

Or actually, I doubt in practice that just pulling the power, as long as it’s not ripping anything at the time, is going to be a problem, especially if you are using an SSD internally.

Edit: yes the instructions say press for 3 seconds to go to deep sleep. You don’t have to wait for clicks or anything like that.

1 Like

It was indeed - I think I called ‘Dead Unitiserve’s Society’… :slight_smile:


That’s the one.

I wonder if anyone have an opinion on the Naim Unit Core compaired to ripping in WAV or wave using a computer ect? Which one have a better SOUND and is it worth the price?

1 Like

I have ripped my entire collection in Wav and Flac on a Uniti Core. I cannot, with hand on heart, say that can consistently say I noticeably discern a difference. I will rip my collection again for my Zenith, probably in Wav, just for the sheer hell of it. :blush:

1 Like

I started ripping on a Mac, continued on a Unitiserve, and used a Core for a little while. At no point could I reliably determine any difference between different rips when played back on the same hardware.


We were discussing this on another threads here I commented

1 Like


You could rip on a PC with freeware or dbPoweramp for £60.

You could rip on an Innuos ripper for 1/3 of price.

The Core has no compelling value proposition.

Thanks for your reply. I am new to this and never thought it is so complicated using dBpoweramp after the second cd rip and the metadata stopped working.

We ripped 1000s of CD using dbPoweramp with AccurateRip, very few issues.

If you want to suffer from metadata issues buy a Core.

I do not want to, just need help to figure out why I stop getting the artwork in dBpoweramp.

No idea why you’d have an issue on artwork only.

We ran all rips through MusicBrainz Picard - very few issues. Nice consistent metadata on all rips.

Try Flac, as I suggested you above and David Hendon too.