Shared Networks Access

Hello. I looked at different posts on network share access and couldn’t find any pertinent one that applied.

The problem is that my Unitiserve disk has been reformatted by the Naim local service provider and I have tried fruitlessly since, so many times, to reconfigure a shared network to be used as a music store. I have a NSSRVB US with 1.7c RC1 and an Asustor AS1102T-0F62 NAS.

I manually set up 2 network shares that seem to be recognized. When I refresh network shares, it always ends up on them being offline.

On connectivity issues that may be pertinent, I have established the following through various attempts to fix the issue:

    1. I wonder if the hard drive is properly configured since I ripped 6 cds and, although there are 2.062 GB available left, the US does not rip any more cds on the basis that there is insufficient space left – if unrelated, I would appreciate anyone telling me how to solve this;
    1. I am able to access the 6 cds ripped only with n-serve and the Windows interface (on bootcamp). When I access the US from iMAC’s Finder, I see the “Music” folder, but all sub-directories (EX, HQ, LQ and MQ) are empty;
    1. SMB is unable on the NAS as showing on the picture;
    1. Hosts information seems correct.

Thanks for any assistance you can provide.

I need to look at this more when I have more time, but the Unitiserve needs SMB1 to work at all. SMB2 is no good.

Also if it were me, I would get it working with its internal music store and then try to set up the shares on your NAS as a later step. If you want a music store on a NAS there are some specific requirements, including that the folder has to be completely empty, without even an empty trash folder in it.

There may be additional issues, but I think you are spot-on: in the NAS SMB config screenshot, it says “highest SMB version: SMB3” and lowest SMB version: SMB2". The Unitiserve will need SMB1 allowed

Exactly. That’s what I noticed too!

Thank you all for your comments. Let me know if you need more details.

David and Sued, while you are looking at the NAS issue (I should have known since I changed it a short while ago), could you explain how I can set up the internal music store to access the 2.062 GB available left for storage?

So this is a Unitiserve SSD you have? No internal hard drive, just a small internal SSD and you are supposed to store the Music Store on a NAS? If that is the case then you won’t get anywhere trying to rip on the unit without the NAS working because the internal SSD will get rapidly full.

2 GB isn’t much room at all (a CD rip is likely to be 100 MB to 200MB or so in size, depending what format you are ripping to) and if that is all your NAS has left then that is the first thing to fix. Also the most important thing of all is that you need to enable SMB1 on the NAS. At the moment your NAS has SMB2 and 3 enabled, but the Unitiserve only understands SMB1, so can’t connect to the NAS even if everything else is right.

Once you have a suitable NAS (I suggest Synology or QNAP) then you can have a go at setting up the Music Store on the NAS. I am not really aware of the details of how to do that, although you will find guides on the Naim website. As you use a Mac, there are more complications but I expect @ChrisSU can guide you.

There is also an issue linked to this in that Windows 10(and 11 I guess) do not support SMB1 out of the box anymore due to ‘security issues’. You have to root about in the settings and switch it on.

Fortunately that isn’t an issue here at all as the OP uses a Mac. And the NAS will use Linux.

Thanks David, I took note of the SBM1 issue and will se what I can do at my end with Asustor.

Back to the internal hard drive, I understand it is a 2 GB. The 1st picture I submitted earlier shows, if I am not mistaken, that drive d:/music is the internal drive and that it has more or less 2 GB available. Is that correct?

Below is also a picture of Music Stores (Bacs de CD) on n-Serve. You will note that the space used reads 0.03 GB and what translate as “free or free space” (Gratuit) is 1.92 GB. Is the set up correctly done? If so, why won’t it take more than 6 CDs WAV ripped?

What should I do to be able to rip more CDs on the internal drive?

If it’s a normal Unitiserve, it would have a 2 TB hard drive, that’s 2000 GB!

2GB is tiny. You might only get six CDs on that.

Is this Unitiserve new to you or were you using it before you got it repaired?

Gents, we are making progress. I change the SMB settings to allow SMB1.
Then, I selected the NAS network share (NaimMusic) as the Music Store.

However, every cd I tried ripping gets ejected after +/- 10 seconds. I don’t understand what stops CDs from being ripped.

I’m sorry that it is so long since I had a Unitiserve that I am not sure what to suggest. @ChrisSU?

I couldn’t believe what I was seeing in the latest screenshot after reading your comment, so I went back to the first screenshot which seems to confirm ~2 GB … something is odd, a 2 GB drive must be so old that it doesn’t even fit (?) Maybe the drive is larger but someone messed up the partitioning?

And @Regnaloub1, you wrote in the first post:

But there are 2.062 MB (!) left (i.e. two thousand MB, which is approx 2 GB) not 2.062 GB (two thousand GB = 2 TB), according to the screenshot. Which would explain why the US refuses to rip “on the basis that there is insufficient space left” - because it is more or less true!

What disk is this and who put it in? It might me a 2 TB drive but somehow it may have been partitioned with just a 2 GB partition, and the rest left unpartitioned and empty? I don’t know, just a guess

From the top screenshot he is trying to set up a host server NSSRVB US , from which I assume he wants to stream. The total file size is only 8gb with only 718mb remaining. Is it this were the problem is? I assume the ripper has to be pointed at either the hard disk or the external store/server.

I had issues with the hard drive and it was reformatted by the local Naim dealer. All that being said, all that matters to me at this point is that I can use the NAS Music Store to received ripped CDs. Any idea how to solve that issue?

Before changing NAS, I think was able to use the NAS (QNAP) as the main Music Store. Does that shed. any light?

OK, I guess the music store in the first screenshot was on the wrong disk because the NAS was not accessible. Did you delete the 6 CDs that had been stored there and filled it up?

I’m wondering if the US might be acting up because it is short on internal disk space for itself. I don’t know if the US rips directly to the NAS or if it first creates a temporary file locally and then copies it to the NAS, but I would guess the latter. If so, it might think that it’s running too low on space and therefore ejects the disc after 10 seconds?

Wild guess but worth a try if you haven’t already deleted these 6 CDs


THANKS!!! Gloria in Excelsis NAIM COMMUNITY! I did delete the 6CDs which, as Suedkiez last mentioned. Somehow, it allowed music to be ripped on the NAS Music Store. I can’t tell you how this whole team work is fantastic, after weeks of searching and going in circles, you provided, all comments included, a resolution to this really problematic issue. Un grand merci!


I would recommend you ensure the format is flac and not wav. The userve is obsolete technology and flacs are more compatible with other tech

Gary, thanks for the tip.