Siri operation on Muso QB?

I quite fancy being able to control my Muso QB1 via voice commands using Siri.
The QB1 is in my garage, so hands are sometimes tied up and or greasy.
I can airplay to my QB from my iPhone.
I would like to be able to say “hey Siri, play ***** on garage QB” or whatever.
In order to do so, I believe I have to add my QB to “Home” on the iPhone.
When I try to do this, “Add accessory” gives me a few options including scanning a QR code (which I don’t have) or, “More options” which then lists my Garage Mu-So QB as well as my NDX2.
If I tap on Garage QB, I get a message stating “Unable to Add Accessory” as well as an Airplay pop-up stating "Unable to connect to “Garage Mu-so Qb”.
Does anyone know what I’m doing wrong or if there is a known issue?
It seems I am able to add my NDX2, so the QB seems to be the issue.

Can’t help, but if it’s possible I would like to do it as well🙏

Perhaps this can help Can't Connect HomeKit-Enabled Accessories Using iPhone? - iGeeksBlog

And maybe if your iPhone is connected to Wifi with 5 ghz and the muso with 2.4 ghz could be a problem, but that is guessing on my part, hope you can find a solution!


I’ve tried all of the above, and also tried using my brand-new iPad which has HomeKit enabled.
My Wi-Fi is currently 2.4 GHz only, so my iPhone and muso are definitely on the same Wi-Fi.
Still no joy.
Thank you for your suggestions.

I thought at first you would need a QB2, but no this should work on first Gen Muso. So good news. Have you updated to the latest firmware? And your iPhone? Sorry I can’t suggest a solution.

Works on my Gen1 muso! Have you paired your QB with your Apple device? Turned Bluetooth on?

You should see connected on the Bluetooth screen. I’ve noticed that my Atom doesn’t appear on this menu as it is in standby. So turn your QB on to pair and connect. Is your QB discoverable on your network? Before pairing ensure Bluetooth is enabled on your QB using the Naim app. This generates the password for pairing.

Good God. Ok…I just got my iPad Pro to play the Mu-so Qb V1 in my basement…stopped it. Couldn’t do it again. And my Nova doesn’t appear under “my devices” under bluetooth.

What command do you use for Siri? What exacrly do you say?

Yes, latest firmware on QB and iPhone.

Yes, Bluetooth is on and yes I can pair the QB to my iPhone, although for Siri asking to play the QB, I thought it would only use the wifi network?

This is what I see:

Then when I select the Muso, I get this message:

The Muso is turned on and I have tried it in Bluetooth pairing mode and with it just turned on.

iPhone 11, running IOS 15.3.1
Naim app 5.23.2
Streamer version 2.0.00. “Firmware is up to date”.

Yes, but you need to establish pairing. Put phone next to muso to set up?

Ok, use Naim app to go to Nova and turn Bluetooth on. When you have made a pair say Hey Siri play Nova!

But what will it play? I mean…how do you control selection of music?

I was standing next to it when I tried.

Make a playlist? Stream Apple Music or anything downloaded to your phone? I’m not at home now so can’t explore. I could play BBC Sounds. You could try Tidal or Qobuz? Any music available on your network. I think you can ask Siri for particular artists once the apps have granted permission.

Not sure what’s the issue then. Sorry!

1 Like

I am wondering about the name of the your device since it has already the garage in the name in the home app, is that because you have named it so? Or could you add a room in the setup, which than failed, I am asking this because when I added my QB2, only after the add I could point to a room for the de ice!

Thanks - I just tried removing “Garage” from the name, simply calling it Muso QB but I still can’t add it to “Home”.
I am beginning to think it’s not possible to add…

It just was a hunch that perhaps the name could be the problem, alas its not the case!
I don’t know if there are people with the QB1 which were succesful in adding it to the Home app?

1 Like