SNAIC seating problem

Hi folks,

I picked up a demo 552 today from my local dealer. When I got it home and tried to insert the 5 pin SNAIC in to the PSU it will only go in about 2-3mm meaning you can’t twist the lock ring.
I’ve tried the same cable in to my Hi-cap and no problem.
My conclusion is the socket on the PSU is either damaged or there’s something stuck in it.

Obviously it will be returned tomorrow as I don’t want to force it, but interested to know whether anyone else has had similar.

Is this the Digital supply you are trying to connect, from the 552 PS to the 552…?


Have you checked the DIN socket carefully? Being a demo unit it may have suffered from someone trying to connect with the plug orientation slightly out and the sockets getting chewed. That being the case, it should be possible to connect but might offer up more resistance than normal.


Yes it’s the digital power.

I’ve had the dealer around and he can’t understand what’s happened. Anyway, we’ve got it working and apparently the sockets can be easily swapped out without returning to the factory… which is great coz it ain’t going back!!! Lol.


Just make sure any furkling is done with the power off.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.