Sonos Port and Naim Supernait 3

I’ve had Sonos for years and slowly upgrading to S2 and just bought a Port and tried to connect to a recently bought Naim Supernait 3.

unfortunately i get a “feedback hum” when I connect the phono out on the Port to either the stream or AV phono sockets on the supernait (have tried with / without av pass though, as well as line out volume on the app as fixed / variable or pass through

at mo not sure if issue is Sonos end or Naim (have posted same question on Sonos forum)

The odd thing is when I play music, the hum goes, but selecting any other input and the hum is there.
Any suggestions ?

It’s a common issue. Try this to sort the hum (assuming the only item connected to the SN3 is the Sonos Port)

image

2 Likes

Yup that fixed it !

Seems nuts to “bodge” something as simple as earthing these days, hey ho…

Thanks for the prompt response

David

1 Like

It’s a bit of a faff to get this right, but in Naim’s defence they pay a great deal of attention to signal grounding, and a Naim system is designed to be grounded through a Naim source into its mains earth. Some non-Naim sources can accommodate this, but cheap consumer stuff like Sonos can’t do it because it has no earth connection through the cheap plugtop power supply it uses.

Fair enough
Just surprised me given I hadn’t had issues on connecting var Sonos devices to B&O, Onkyo, Sony or denon kit I’ve had in the past and whilst the new Sonos Port as you say has a cheap ac adapter the previous Sonos connect was not earthed either so not sure what’s different- just relieved it’s fixed

Once again thanks for the assistance