Streaming breaking up to Atom

Morning Folks-
I’ve only just started streaming from Idagio.
When it’s working it’s great, but over the period of an hour, the stream will breakup 2 or 3 times which is frustrating. I have to pause the stream, wait about 15 seconds and restart it, then it’s ok until the next time it breaks up.
I assumed I probably need a wifi booster, so asked on the Plusnet Forum (who supplied my Hub2 Router) for recommendations.
They didn’t recommend any and suggested that an ethernet cable was the only reliable solution.
That may be the case, but I don’t intend to run a cable from the router to the Atom.
As an alternative they suggested a Gigabit Powerline -

I thought that in this day and age, wifi streaming would have matured so that it actually works, but the advice I’ve been given seems to suggest it’s still not reliable.

Any thoughts, suggestions or advice please as to what I should do?

I tried using Power Lines, absolute disaster.

Plus Net use BT kit and they do a Wi-Fi extender disc which I have successfully previously.

Do Plus Net do these, would be worth asking them.


1 Like

The WiFi performance of the Atom is pretty good, and in a robust network it should be reliable. Yes, you can eliminate some of the variables with Ethernet and that might solve your problem. As a test, I would recommend temporarily using an Ethernet cable to see if it prevents dropouts.
Powerline adapters like the one you refer to can help, but they can also introduce further issues as they put RFI everywhere and don’t conform to Ethernet standards. Personally I would avoid them.

How are you streaming Idagio? Are you using a high res stream (higher than CD quality?) and if so, are you using Chromecast which, while technically able to support 24/192 streams, can struggle with them regardless of your home network performance.
If possible, try reducing the stream down to 16/44.1 as a test to see if that improves performance.

1 Like

How strong is your WiFi signal was anybody streaming tv at the same time , plus how far from the router is your Atom and do you have thick stone walls blocking signal etc.
I installed 3 tplink Deco mesh discs and have no drop outs anywhere inside or out. You turn off the Plusnet router WiFi and use the deco instead. Nb you can set the password to be same as the Plusnet one to avoid having to reconnect everything.

1 Like

There are repeaters that work with Plusnet apparently, but several users on the Plusnet form say they’re not recommended as they can boost signals I don’t want alongside signals I do want.
But it’s something I’ll bear in mind.

Cheers @ChrisSU yes I tried a cable to another streaming device (Majority Quadriga streaming radio) that has the same issue.
Using an ethernet cable gave perfect results, but I’m not running a really long cable around my recently refurbished house.
I could easily have had a cable put in then, but I didn’t on the assumption that these days everyone steams media by wifi. It’s only now I’m starting to realize that lossless wifi streaming isn’t possible. I’d assumed wifi streaming in 2023 would work reliably.

Idagio only offers streaming at 16/44.1 which is what I’m having trouble with.
I am using Chromecast as I’m not aware of any other way of doing it.

Thanks @Proterra
Wifi signal strength at the Atom is around -50 to -60 dbm according to wifi Analyzer.
There’s no one else here, so it’s just me streaming.
The distance between router and the Atom is 7.33m.
The router is behind an internal dividing wall that is not load bearing, so probably breeze blocks. There’s nothing else in between.

The Channels display on the Analyzer showed several routers all using Channel 11 including mine, so I was advised on the Plusnet Forum to change my router to Channel 1. That has helped but hasn’t resolved the problem.

The TP-Link Deco sounds good, but I see there’s no way to change channels using this router, so I could end up back on Channel 11 and there’s nothing I could do about it.

You may find that Chromecast is more of a limiting factor than your WiFi as it has a small buffer and a basic implementation that sucks up the resources of the processor in the Atom. So before you throw time and money at your home network you might want to look at this. You don’t have many options, although Airplay might be worth a try from a suitable device.

If you do look to improve your LAN it might be possible simply by changing the location of your router. For example, they often work better when placed high up, close to ceiling level. I don’t know what Plusnet give you, but you could disable its WiFi and add some decent Mesh WiFi devices around your home. If one of these is close to the Atom, you could then connect it with an Ethernet cable, although you may find that it is unnecessary.

1 Like

Assuming the Atom is connected via 2.4GHz*, I would try connecting the Atom via 5GHz (802.1ac). Whilst 5GHz has shorter range than 2.4GHz, 802.1ac supported by both the Hub2 and Aton offer much greater bandwidth. You’ll get the greatest bandwidth @ 80MHz channel width, at the expense of range, so I’d start there.

(* Wifi Analyser shows either 2.4GHz or 5GHz, and won’t tell you which your Atom is connected to. It’s that long since I’ve connected by Nova via wifi that I can’t remember if the display indicates detailed connection info - your Hub2 will definitely display connection information, however.)

(If 2.4GHz and 5GHz use the same SSID you may need to vary transmission power or employ band steering if supported. You could temporarily disable 2.4GHz first to see if 5GHz brings any improvement.)

1 Like

Thanks @ChrisSU that’s interesting.
I don’t have any Apple kit at all, so I guess Airplay is not an option.
If I moved from Idagio to Qobuz would that make any difference? From what I can see that also uses Chromecast.

I’ve tried moving the router close to the ceiling but the sig strength fell from -45dmb to -75dbm (2.4GHz) and -70dbm to -90dbm (5GHz)

I’ve had a look at Mesh kit and it looks good.
Is there any product you could recommend for a 3 bed semi house?
This kit gets good reviews-

They guys from The Audiobarn will be bringing my new speakers sometime in the next week, so I’ll see what suggestions they have.

Thanks @Ansible212
I tried disabling the 2.4GHz channel and it all worked fine.
The 5GHz signal is poor at -90dbm but playback was ok with just a few dropouts, but no garbled signal.
In fact yesterday it streamed all day with only a couple of disruptions.
The Plusnet app shows that the Atom is using 5GHz

I can’t find anything on the PlusNet app that mentions SSID

Qobuz (and Tidal) are fully supported by the Atom, so you don’t have to use Chromecast or Airplay. So if Chromecast is contributing to your problem it could be a solution. Possibly also a sound quality improvement.
I would suggest you sign up for Qobuz and see how it goes. They usually offer free trials, so it’s easy to cancel if you change your mind.
Qobuz offers a large amount of its catalogue in higher res format, 24 bit streams rather than the regular 16 bit of CD. Of course this puts a higher demand on your network so despite the improved implementation in the streamer, it may or may not help. You can easily switch between 16/44.1, 24/96 and 24/192 in the Naim app settings.

If you try the above and still have problems, there are plenty of mesh devices to choose from. I haven’t tried the Asus kit you mentioned, but I can’t see why it wouldn’t work well.

1 Like

You’d expect 5GHz signal strength to be poorer, however -90dBm is a marginal signal.

(I don’t recall if the Naim app reports signal strength for wirelessly connected devices, however you should be able to see this by accessing the Atom via a web browser using it’s IP address.)

SSID is essentially the name of the wifi network (SSID = Service Set Identifier)

1 Like

Thought I’d post an update.
Having had so many problems streaming from Idagio, a few days ago I took out a trial subscribscription to Qobuz.
Using Qobuz inside the Naim app I’m able to stream at 192/24 - streaming at 192/24 is not possible outside of the Naim app as far as I understand.

Despite the poor 5GHz signal my Atom is receiving it has played 192/24 faultlessly for more than 2 days now.
As a test I’ve just been streaming their 192/24 collections and I have not noticed a single dropout!
Well done Naim!
It’s also saved me about £400 on wifi extenders

I do prefer Idagio, but the quality of Qobuz within in the Naim app is amazing!

The Deco optimises the channels for best coverage so if channel 11 is crowded it will move things

1 Like

Oh yes it is! We’ll sort of. If you have an iPhone and you use the Qobuz app, then you can get 192/24 into the phone. Then you can use a USB DAC with the necessary adaptor to bring the audio out as analog. You can connect that directly to an analog input on your streamer.

USB DACs are quite cheap and much better than you might expect. I recommend the Audioquest Dragonfly range. The Cobalt is the best, but personally I like the sound of the Red better.

I expect it’s possible to take the digital out of the iPhone and connect it to a digital input on your Naim streamer. I’ve never managed to get that to work, but I haven’t tried with a modern Naim streamer and someone out there will know a simple way I expect.

1 Like

Interesting, but I’ve never owned any Apple device

Probably works with Android too, but I’ve never owned an Android device.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.