Superuniti not picking up new Synology NAS

Hi – can someone please offer advice on how to solve this ‘communication’ issue between my Superuniti and new Synology NAS server? As it stands, communication seems to be restricted to one direction as described below and I can’t make use of the SU or Naim app for streaming. My equipment is as follows: -

  1. BT Home Smart Hub 2 with a local BT Wi-Fi Disk satellite unit near the Superuniti
  2. New Synology DS220J Disk Station NAS server
  3. Naim Superuniti (c. 10 years old, but recently serviced by Naim)
  4. Netgear switch box (the BT Disc unit, Synology NAS and Superuniti are each connected to this)
  5. Apple MacBook Pro laptop (M1) with external CD drive
  6. Naim app operated through IPad Pro and Iphone

Due to a problem with a previous - and now unsupported (ReadyNas) server - I purchased the new Synology NAS above. I’m trying to set this up and have already started to re-rip my CD collection successfully (I think I’ve also lost a fair amount of downloaded music on the old ReadyNas, but that’s another story!).

Anyway, my problem is one of communication between the units and I’m hoping there’s a simple solution. The problem is: -

a) The Synology Disk Station is set up and can communicate with the MacBook Pro, so I’m able to rip CDs to the server and can confirm this by opening the Synology server’s files through the laptop.
b) When I access the Synology’s Audio Station’s dashboard, I can see the ripped CDs and – by using Audio Station – can send one at a time to the Superuniti for playing. So, the Synology clearly ‘sees’ the SU and can send files to it.
c) BUT – when I try to use the Naim app to access and play my music files – it does not recognise the Synology and states that no server is found. This is the case whether I go through the control buttons on the front of the SU, the Naim handset, or if I try using the app on the iPad or iPhone.

NB – I can use the apps perfectly well to access internet radio stations and all other inputs on the SU.

Not being particularly tech savvy, I’ve tried obvious things like shutting down all the units and re-starting each one in order (hub, server, SU, apple equipment), and deleting and reloading the Naim app, but with no success. I’ve also read that BT Hub 2s can be problematic, but it seems to be working just fine in ripping CDs etc.

So, can anyone please give me a steer on how I can get the SU and Naim apps to recognise and control the Synology server? If so, it would be greatly appreciated.

Happy holiday everyone.

Hi, you need to have upnp software running on the nas; try either asset or minimserver.
Maybe audio station supports this; look for a setting to enable dlna/upnp.

Robert-h has the problem I.D.’d …. you need to install UPnP on the Synology.
Synology have UPnP software called ‘Media Server’, in a preinstalled package that’s comes with the machine.
Just find it in the software store and hit the install button.

That said, it’s not the most able UPnP and sooner or later you might be tempted to do better, and again Robert has it I.D.’d.
IME Minimserver is best for a classical music collection as it handles the permutations of composers and orchestras better, whereas Asset UPnP is best for rock, folk & jazz.

Or identified, as one might say…

1 Like

Screenshot 2023-04-07 at 23.56.24
So it looks like you are using the built in UpnP server. I’ve not tried this on my Synology, but instead went for Asset, which is recommended by many on this Forum (as is Minimserver)

To check it’s running OK on the NAS, then you should also be able to see your Music from your Mac. Suggest you install VLC player and click on Universal PlugnPlay, and check to see if your Asset Station is shown on the right hand Panel - you shook be able to navigate trough your music and play it all within VLC.

I don’t believe Audio Station is a UPnP for streaming, it gives the ability to connect remotely over internet so you can use the NAS files away from home.
As said in my previous post ‘Media Server’ is the Synology packaged UPnP software.

Not sure, but I must admit I never looked closely at it, but the description of the app says;

" Plays and streams music through web browsers, mobile devices, DLNA-certified devices, and AirPlay-certified devices, and displays songs in the play queue"

I also came across the following statement on Wiki

" If IGMP snooping is enabled on a switch, or more commonly a wireless router/switch, it will interfere with UPnP/DLNA device discovery (SSDP) if incorrectly or incompletely configured (e.g. without an active querier or IGMP proxy), making UPnP appear unreliable"

…so that may be worth checking on the switch

IGMP snooping should not be an issue in this case, the BT Smarthub-2 and if Percybass‘s Netgear switch is a simple unmanaged model, there are no user configurable settings for Multicast and IGMP

Synology Media Server is fine to get you going; just make sure you set the server to transcode to WAV for best sound quality on the SuperUniti (assuming you’ve ripped to FLAC?)

During the time I used Media Server I found transcoding poor with highres & it didn’t play gapless.
24 bit is streamed as 16 bit & the gapless transitions just don’t work smoothly.
OK time haas passed & they may have sorted it.
My advise is go to Asset UPnP

Thanks very much to you all for your very helpful and speedy advice. It’s much appreciated.
I’ve got a full holiday weekend planned, so won’t be able to knuckle down to your suggestions for a couple of days, but I’ll certainly take them on board.
Thanks again everyone and have a great weekend as well.

1 Like

Update time.
I’d like to say thanks again to all who got back to me with advice. This was really helpful. I’ve now got Asset loaded on my system and have set up transcoding to WAV. Everything’s working well (fingers crossed) and sounding great.
All the best.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.