System automation 552 + NDX2

Just added an NDX2 to my 552 and connected a 3.5mm to RCA going into RC5 on the 552. Turned on Automation in the naim app and checked both Classic and RC5 and chosen preamp 2 since my hiline goes into input 2. Still I cannot control volume. What do I miss out?

I’m pretty sure you don’t need RC5 Modulation turned on with a 552, although I’ve no idea if this is causing your problem.

Have you enabled Preamp 2 in the System Automation menu, as oppoosed to the app home page, from which that input should then disappear?

Did you restart both boxes after making changes?

The Preamp 2 input is not selectable to turn on/off as the other inputs are. Is that because it is used? I only have this input connected for now. Have not re-started the boxes but have re-started the app.


EDIT: One need to use the WHITE/NEGATIVE RCA connector if you use a 3.5mm to 2x RCA. The red/positive one does not work :slight_smile: Working now!

1 Like

Ah, yes, with a stereo lead you have a 50:50 chance that it will work!

We bought a mono lead (3.5mm to 1xRCA) for 252 for 2 quid with gold plated connector!

But why is it not possible to activate/disable preamp input 2? All other inputs are possible.

And is there no way turning USB and iRadio off in the naim app as all other inputs?


Pre amp 1 selected on my 552.

But if you go into Input selection and look at preamp 1-6. Can you activate&deactivate them all? I can do it on all except preamp 2. I can get all inputs on the home screen except preamp 2 :man_shrugging:

Preamp 2 (in your case) is always in use by default because it’s the device that the app sees, and which passes on control commands to the preamp via SA.
In the app you wouldn’t select the streamer an a preamp input, you would select the streaming input (server, Qobuz etc.) from the same list.

Bit confused :slight_smile: What if I use preamp 1 for my phono stage and want to go back to preamp 2 and stream Roon. I cannot chose that input then through the app?

Just select the streamer from Roon and it should play.

1 Like

……you can’t select more than one input at the same time in the Naim app. If you select a streamer input, the app knows that you will need Preamp 2 so opens it. It’s a neat solution, but a little confusing as two sets if inputs (streamer and preamp) are combined into a single list.

Roon, AirPlay, Spotify etc are selected within their own apps, just to add to the confusion.

The inability to hide the USB input is a source of frustration for us too.

We will never ever use the USB input to our NDX2 but cannot get rid.

1 Like

It’s mildly irritating, but at least now you can re-order the inputs so that it’s at the bottom of the list, potentially on a second page you don’t otherwise use.

Lol yes already done

p.s. telly goes to NDX2 (optical) as it sounded slightly better than straight into nDAC so that’s one question answered. No idea why it’s just bits :laughing:

You just need one more input to bump USB off the page. Time to buy a turntable :wink:

That goes to stageline/252 when 300 arrives :smile:

But you will still be able to add it as an input on the app.

Didn’t realise that. Think the Stageline will be on Aux2 on 252. Guess we’ll have a play with system automation once final setup in place T-7 weeks.

@IainO @Slamdam
On my Nova, The usb input can be disabled by using the web client and then will not show on menu page, I think this is the same for other devices as well
From web browser type address of streamer or unit device and under inputs select disable usb.

1 Like