Tidal and Uniti Star


Is anyone else having issues with Tidal playing music through the Naim app?

The app logs me in and I can browse fine, I can play music through my other phones and can happily stream via AirPlay but it will not play anything anymore via the app.

I’ve logged in/out many times … tried changing the stream quality from high to normal … even reinstalled the app … nothing … tried on different phones and no joy either.

Fed up with the issues I have with this … wanting to sell :frowning:

You didn’t mention it, but did you try restarting your Star (I mean a power off restart, not just wake up from standby).



Yeah tried that too :slight_smile: no joy

Ok the other question I have is about how your Star is connected to your router. Is it WiFi or ethernet cable? If WiFi then it would be worth buying a cheap long cat5e ethernet cable and temporarily connect it that way.


Hi, Ethernet… have no issues streaming from my qnap nas

Was working last week then it just stopped when I was loading a new tidal track and refuses to open anything now on tidal.

I’m almost out of ideas. One other thing which sometimes fixes a problem even though everything else works and you can’t see why it is relevant is to restart your router.

If you haven’t tried that then turn the router and the Star off, restart the router and once it has settled, restart your Star. You will probably want to restart your NAS too.


A couple of questions:

How many devices do you have logged into your Tidal account? You mention other phones, there is a limit to how many devices can be used at one time.

Do other online sources work?

Will try … that would be odd if it works after that!

3 phones and have the premium account. Only two using it though

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.