Tidal App Error in NDX

I can’t seem to play Tidal via my NDX app anymore. Getting a message on the NDX saying 'Unable to Play". I’ve taken the following actions

  • Signed in and out of the Tidal App
  • Restarted the NDX and pulled the network cable out
  • Restarted the app
  • checked for any updates to NAIM/Tidal apps

Any other check/ideas are welcome. Thanks

Tidal caused me some issues last night. Still saying ‘network error’ this morning until I deleted and reinstalled the app on my iPad.

Working now.


thanks, is that the NAIM app you re installed? cheers M

Sorry no, the Tidal app. Reinstalling the naim app might work too though.


Unfortunately that hasn’t worked for me. Wonder if there might be others experiencing the same problem?

Same thing here… Tried it the other day and also playing up.

Rebooted/restarted/etc… given up. Subscription cancelled. Life’s too short.

That told 'em! They won’t mess with you again :wink:

thats disappointing -guess we need to cancel as well!

tbh I was very rarely using the service… I just found it annoying the one time I try to I waste half an hour and still don’t get anywhere. The ‘app’ says files added to the queue. The NDX says ‘stopped. press play to continue’. You do and it then says something like error with the format and skips all of the files. It’s also a pain getting back to ‘normal’ operation. I found the only way was reboot the tablet and the NDX!

FWIW - I have had a NDX for about 12 months with TIDAL via the NAIM App and it has been working without any issues. Prior to the NDX I used Tidal with my ND5 XS. I also use TIDAL through their app with my MAC Air and iPhone without experiencing any issues. There were some issues prior to that with music dropping but that issue has not raised its head in a very long time.

Perhaps I have jinxed myself by chiming in but I have had a very good experience with TIDAL and find I get my monies worth for the monthly subscription fee.

I’ve used it on and off for many years with no real problems . Enjoy the sound quality. So quite disappointed with the current state.

I have the same problem. Via chrome cast it does work, however with the native integration it does not work anymore. This used to work great. I could not find a solution on the forum. Any tips/tricks?

i’ve tried everything recommended here. afraid the only option is to cancel for me.

Have you been following the ‘other’ thread on this topic? There’s a lot more info and thoughts there. No solutions but at least a better explanation etc… of what the current ideas are on this issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.