Tidal issue with iPhone

Is anyone having issues with Tidal Connect using an iOS device? I can open Tidal Connect and search for artists and tracks. But tracks don’t want to play.

I tried using Tidal’s app. Everything works, and I can use Airplay to connect to my ND5XS2. So it seems Tidal Connect is the one with the issue.

I just noticed this after the Naim App updated to 5.24……

Hi.
I can’t reproduce this on an iPad or iPhone running the latest app update. All working ok for me here.

I really don’t know what happened, but a power down sorted everything.

From time to time both the connect device and the option of using chromecast is not available. Usually it appears again after turning on or off whifi on the phone, but not always. In other apps chromecast also seems to sometimes not be available but I have not found a pattern to this. A while back hwen co my connect streamer never showed up I locked out from tidal both in the app and in the naim app. Logged back in first in tidal then in the naim app and that almost solved the problem for a while.
Claus