Tidal not workingbon ND5XS

Hi guys, my Tidal is not working on ND5XS, it’s already updated to the newest version 4.8, and download the newest android app, can anyone help on this please as now mainly listen to Tidal, thanks so much for the help.

logged out, cycled the power on both the control (phone/tablet) and ND5XS, and logged back in again?

can confirm Tidal’s working on my 172

Tidal working fine today on my ND5 XS.

every time my legacy streamer (NDX, 172) stops working w Tidal, a simple power cycle fixes the problem. If that doesn’t do it, the log out/log in approach then fixes whatever the issue is. Normally happens every few weeks and I’m happy to manually intervene vs upgrading…

Thanks so much Maury, tried that but still doesn’t work, same messages appeared…do you think it will work if I downgrade to previous version for ND5XS? Thanks

That’s a bummer. I would strongly advise against downgrading your firmware, though. The engineers spend way more time testing upgrade releases than they do downgrades…

do you have another Android device you can use? or better yet an iOS one?

by the way - i assume Tidal is working fine on your Android device (i.e. you can login, listen to music on the phone/tablet, etc.) ??

The 4.8 firmware included updates to improve Tidal stability, so rolling back to an earlier version is not a good idea.
Did you factory reset the streamer after updating it? If not, try it now.

Has Tidal worked in the past on your Naim streamer? If not, there could be a login issue. Go to Tidal’s website, change your login password, then use the new password to log in on the Naim app.

(Without a firm diagnosis of your problem I can’t promise that either of the above will help, but there’s nothing to lose by trying.)

@ChrisSU @Maury_Finkle @MrFixit Thank you all guys, have finally figured out what the problem is, I tested out with other Android device and found that it doesn’t work on my Android Honor branded phone, as the app is downloaded via Play Store, will email to Naim and see if there is any solutions to this issue.

Thank you very much again for all of your help.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.