Ubiquiti UniFi network and Naim Core

Anybody out there happen to have a full UniFi network (ideally with UXG gateway and Gen2 switches) and running a Core as storage and UPnP server…?

All working OK…? Any issues, particularly around UPnP playback and ‘Standby’ mode…?

I’m trying to hone in on an issue I’m experiencing…I’m 99%+ certain it is not network related, but willing to be open to the possibility there may be something odd/incompatible re a setting (i.e like the renowned RSTP issues with Sonos systems etc) ….
I’ve just about tried everything I can think of…and don’t have much hair left….As I say, really feel it isn’t network (hardly ever have any general network issues (I work in network install), all other streaming types good, no discovery issues, App responsive etc etc etc……but just throwing the net out there to see if anyone else had a similar set up and can report….


What issues are you experiencing?

I only have a uniti, no issues here on full unifi setup.

Hey garyi (I was aware you were UniFi based) –

The Core often and repeatedly wakes itself from ‘Standby’ mode (and even sometimes when it’s already full on!) – which I’m assured it shouldn’t do, even whilst UPnP streaming……and 50%+ of the times when it happens, it then interrupts the play, skips a handful of tracks, and then carries on……

I’ve tried all the basics and more….As I say, I’m fairly confident it isn’t a network setting….iRadio streams work fine all day long…as does Airplay….I don’t have any network ‘issues’ (generally or re audio) – Everything is Cat6 except the phone – the Naim App is fine, no discovery issues, no drop outs of any kind……Just this issue with the Core, which is recently purchased (and also a replacement unit after I deemed the previous one must have been defective)….

Multicast DNS is On, IGMP Snooping is On …etc etc….I’m currently running a ‘flat’ network (just on a temp setup with the Mini TL Rack whilst some house renovations are happening) with a 255.255.252 mask, nothing complicated on the firewall except a couple of Port Forwards for NAS’s ….All pretty straight forward really and nothing that should be causing an issue……I’m currently Double NAT after the ISP modem as I’m just waiting until I’m properly sorted re main rack and throwing into Bridge mode….but that shouldn’t really make any difference to the Core’s functionality – if it was that sensitive, presumably Naim would be advising of Ports required to be open etc…

It’s like a WOL event in a way….but then there’s nothing that could be triggering that, as far as I’m aware…I sort of feel it’s Read/Write based issue or some sort of memory issue….Like when the Core is asked to do something (i.e add an album to an already playing Playlist and then just as that new section is about to start playing…it will often trigger the issue) ……Logic would point towards the internal SSD/HDD – but I’ve been through all that, swapped out and even played from USB external……

I’ve emailed Naim Support (on the back of some previous emails, not sure whether a new ticket needs to be started) some days back, but nothing yet received……I’m going to start a separate Post on it all and run through everything, but I just wanted to throw this out re UniFi and if there could be anything weird there……though, doesn’t make any sense to me……

Getting pretty fed up though, that’s for sure…!:pensive:


Humm that is odd, the core is a glorified computer at the end of it all, but I don’t imagine it has wol.

I understand that double nat is not ideal so I guess it could be prudent to wait u til you sort that to be sure. I am on virgin in modem only mode. But as I say don’t have the ‘modern’ streamer.

I could t totally rule out the router. I am on fireangel connect for my smoke alarms and that would not maintain a cloud connection for more than 24 hours on my dream machine, when I went to dream machine SE, same software it worked perfect.

Man I have fireangel some hassle over that lol.

1 Like

Exactly….I even got to thinking perhaps it was PoE on the USW Pro Switch (I’ve seen UniFi switches indicate PoE icon even when connected to a non PoE device) or some sort of slight voltage being sensed or something….so duly turned off PoE on said Port, then plugged into another non PoE port of another standard USW switch…and then even tried putting a dumb passive 5 port Netgear in line….All made no difference in the end………Also tried disabling STP on connected port…(haven’t yet tried disabling STP/RSTP globallly….but then don’t really see that I should have to) ……

Yeah….UniFi….Can be a PIA at times for the oddest thing……and then most brilliant at others……! :man_shrugging:

I just don’t feel, in my gut, that it’s network based….If there was some sort of packet block or something similar, then it would just be a drop out or disruption etc……I don’t understand the physical side of this – that the Core is Powering itself On………


I suppose the quick test is unhook the Ethernet and check behaviour, it does not rule out either side but could give some clues

I did actually try that last w’end – also as a kind of soak test to see if it was power related….Sods law, the Core remained in standby for 2 days and didn’t wake up…! But then, it doesn’t do so as often from Standby when not in use (it’s more when in use and of course, it needs to be network connected), so I couldn’t be sure it wasn’t a coincidence or if it was pointing towards being on the network……

But again, it still doesn’t explain in my head why the Core would be powering up from a network event/issue…….Of course, there could be a slight firmware issue on the Core that isn’t handling something quite right……I don’t know….

I will do another post and list everything I’ve tried……

Think I’ll pull the Ethernet again now for a bit, see what happens again this time ….


That’s enough to drive a person insane. Afraid I don’t have anything to offer except sympathy as I don’t have a Core, but my UDM Pro / U6 LR and PoE switches are rock solid.

Maybe Naim could tell you what the network commands are that the Core might be responding to?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.