Unable to connect to “Folk Alley”

Just wondered whether anyone else has been unable to connect to “Folk Alley” today. Coming up with the msg. “Cannot open Radio Station Folk Alley” on the Naim app.

Same here. Well,not getting that message but I can’t see a stream playing.

I just hope it hasn’t been removed. A big favourite in this house.

It’s playing from the website, so I hope a temporary glitch, if not the URLs are on the website and you could add them to Vtuner for your MAC addresses. (I think, it’s a long time and a change of streamer since I did that.) Copying in @Stevesky in case there is an issue he can help resolve.

Many thanks. Paul.

I am missing it too, but I note that the 4 subsidiary streams (Fresh Cuts et al) are working. Help please, Naim, and thanks in anticipation.


Folk Alley link is now updated on Naim’s Choice. Also have let VTuner know to update their database as well.




Thanks Steve.

Yes, thank you very much indeed, Steve. Another threat to civilisation narrowly averted!

Still unable to connect (NDS).
Is there something I should do?

I have been able to stream Folk Alley on the n-serve app by going into Genre-Folk-USA-Folk Alley. Hope this helps.

Many thanks for that.
All the “specialist” Folk Alley streams play, but still not the main one. (via Naim app Android and iOS).
I make do by casting from Folk Alley app on
phone to Chromecast Audio into the optical input of the NDS

Hi @mlgh

We’ve taken another look and hopefully it will now work on the older green screen products.

Try playing from Naim’s Choice->Folk Alley.



1 Like

Excellent, many thanks. That’s sorted it!

1 Like

Folk Alley played fine for me using Roon yesterday.

Both Naim Radio and Naim Jazz are really good quality :+1:

1 Like

This situation seems to have cropped up again…
“Can’t Play”.

Managed to get it working by searching via genre/folk/United States/Folk Alley, (as suggested by sacdfan above) and adding to favourites.
But link in Naim’s Choice not working, for me anyway.

Another folk alley strangeness. On my ns01 I have a 320 kbps stream, that worked for some time but now it seems the stream is 128 kbps like the streams on the new platform. How I found the 320 kbps stream and why it has disappeared again I do not know.

Hi All,

Earlier this week we had to do a small tweak to get around a https TLS1.3 issue on FolkAlleys side. All back to normal now.

Folk Alley - for a while Folk exposed a 320k MP3 stream, but they discontinued it unfortunately. If you’re a Folk Alley subscriber then suggest write to them that a higher quality stream is wanted. I think AAC 192kHz MPEG4 is an excellent compromise of sound quality vs data usage. Low bit rate MP3 is the worst of all worlds.


Steve Harris
Software Director
Naim Audio Ltd.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.