Unable to Link my HDX to my Synology DS218+

Hi Everyone, I’m hoping that I can get some help with how to input the correct string information into my HDX to network it to my newly acquired Synology DS218+ (2x2Tb iron wolf hd)
I am totally new to the NAS world and love HIFI & have a NAIM HDX 2 TB Ripper Streamer that stores my WAV music on its internal drive, this works really well but the reason I am asking for help is that there is a facility to back up the music files from it into the NAS , (hence also the reason for my purchase of this device).
As I am a total newbie to this I have tried unsuccessfully to find a way to link the 2 devices over my LAN with the protocols that are needed.
I Have an 8 way unmanaged switch that everything goes through, every unit sees each other there is just the protocol string that I need to input into the HDX which I’m not sure on what to input in and the setup on the NAS on how to share it with the HDX that I’m sadly unable to get right.
I use a Win 10 Pro 64bit PC that shows all devices and a front end view when I input the HDX’s IP address into it similar to the Synology one that I can enter the data string to create a “network share” as it’s called on the HDX.
Any help from you all would be very appreciated !
Thanks & Kind regards

Hi Symonz,

maybe page 21 of the HDX reference manual helps.

Basically you have to create a share on your Synology, enable SMB file service and add the share to the HDX as shown in the manual.

Kind regards,

Hi Mark
I’ve created the share in my Synology NAS
BUT need to know the exact wording string that the HDX needs to be inputted in, and as the handbook doesn’t quote any wording to input then I’m still in the dark as to what to input to make the “network share” work

I assume in Windows you see your Synology as DISKSTATION?

So you would use \DISKSTATION\name_of_your_share, i.e. \DISKSTATION\hdx

I’ve called my disc-station SYNAS
So I assume that it’s //SYNAS/ HDX


with backslashes (2 at the beginning - missed one in my last post).

Give it a try! :slightly_smiling_face:

Hi Michael
I tried this is went further than it’s ever gone
BUT now reports


Have you created a separate user account on your Synology for the HDX to login?

Control panel > User > Create

i.e. Name: HDX

Then give that user permission to access the share:

Shared Folder > HDX > Edit > Permissions

Set permissions for HDX to Read/Write

In File Station check the permissions of the directories (LQ, MQ,…) in the HDX share. Select each and go to Action > Properties > Permission


Smb has moved on since the days of windows xp I think this is going to become more and more of an issue with people I would imagine the nas is using smb 3.

1 Like

Default on (my) DiskStation is a maximum SMB protocol version 2.

1 Like

I’m now getting SYSTEM ERROR 71 after I try to create a network share

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.