Unable to set up QB2


First-time poster and first-time Naim customer.

I’m facing issues trying to set up my recently purchased Naim Mu-so QB2 wireless speaker.

I simply cannot get it to connect to wi-fi.

I’m using the Focal & Naim Android app.

So, I power up the speaker and shortly the status light starts flashing purple.

I fire up the Android app and I’m asked to select the product I’m setting up.

There is only one choice, Mu-so QB 0333 - [0333] are the last four digits of the serial number so it’s definitely the right device.

Then I’m asked to input and confirm my wi-fi network password.

I’m then asked if I’d like to create a temporary Wifi network with the device.

Then I get ‘Transferring settings’ for a while and then ‘Waiting for Network’ for a loooong while.

Then I get…

Failed To Connect
Unable to detect Naim product on your Wifi network.
Device may have been unable to join. Wifi credentials
Could have been incorrect.

I click OK and then I’m back to the status indicator screen.

I can assure you I know my wi-fi password and I’ve entered it correctly.

I’ve tried the app on a Google Nexus 7 Android phone and a top-end Chromebook.

I’ve gone through this process about ten times and I’m getting highly p1ssed off.

Am I missing something really simple? Am I an idiot (possibly)?

What the hell am I to do?

I thought Naim is supposed to be good gear.

Any thoughts or suggestions gratefully received.


There is a device [Mu-so Qb 0333.d065] on my wi-fi network with an IP Address of

But I can’t access it with the app and it doesn’t respond to pings???

1 Like

Hi Totes, welcome aboard.
Every once in a while this kind of problem pops up. Usual suggestions include trying a wired setup to see if everything is working ok through a hard connection.
Once established that there is no other issues, go through the factory reset process and start WiFi setup again.
Occasionally, WiFi setups go awry and some settings have taken but not worked correctly.
Wiping and starting again will generally resolve any settings issues.
I have had a problem in the past with one of my MuSo 2’s, but both are now hard wired.
Good luck :crossed_fingers:t3:

Using the Google Home Android app to set up the inbuilt Chromecast seems to have sorted things out. Had to wait a long time for it to connect to wi-fi but it got there in the end.

Here’s hoping…

1 Like

I live in quite cramped conditions and the whole point in acquiring a wireless speaker was to preclude hard-wiring.

1 Like

Not uncommon for muso 2s to have issues with Wi-Fi. Mine had to be returned to Salisbury. Been fine since.

1 Like

There is another possibility, which I have forgotten the details of, but is basically the WiFi saying to itself “my security configuration doesn’t allow me to respond to this request because I don’t know this unit”.

It happened to me with a muso Qb1 in a holiday rental property and as I couldn’t get access to the router, I was never able to change the relevant setting and finish the registration process.

It is.

Assuming this unit is new, have you contacted your Naim dealer…?
It’s their job to help you… :thinking: