Uniti 2 bricked?

Hello, I’m new to this forum, and actually new to Naim.

I bought a secondhand Uniti 2 a few days ago, and it played perfect until now.
An hour ago I tried to start an Internet Radio station through the Naim iPad app, but the app couldn’t connect to the Uniti 2.
Then I tried starting the radio with the buttons on the Uniti 2 itself.
Nothing happened, and after about 20 seconds the message " Streamer Update please wait" appeared on the screen, and until now it still is.
Looks like the ethernet connection is not working, because I cannot see the Uniti 2 in my router, or on my network. And also the led’s near the ethernetport are not blinking.

Tried to power down the Uniti 2, and disconnected the powercable too, but after a few minutes waiting and then reconnecting and rebooting the unit I get immediately the same message.
Looks like the unit is bricked or something? :worried:

Does this sound familiar, and anyone knows a solution?

That is frustrating for you. When powering back on, I guess you have scrolled through the non-network inputs such as Cd etc with no joy either?

I tried changing the input, but the unit is not responding to anything. Not on the buttons on the unit itself, and also not on remote.

Trying to edit my first post, but can’t figure out how to do that. Maybe it’s a limitation for a new member like me?
Would like to edit the thread title, because ‘bricked’ isn’t maybe clear enough to anybody.
The word ‘Fault’ would be more common I guess. Maybe a mod can arrange this?

Anyhow, I’m searching the internet for a way to hard-reset the Uniti 2, but can’t find a way. Anyone knows the trick?

Perhaps let it finish updating and not mess with it until it is finished.

@ElMarko That’s new for me. Because for what I’ve read the updates cannot be done through the ethernet/wifi, but must always be done manually by usb/rs232 connection and a laptop.
Or am I wrong?

Anyway, I left it on about an hour, and nothing happened (or finished). So, in the case that updates can be automatically done online, how long do they take to finish?

I’m not sure about the Uniti2 and only responded the way I did b/c you said it was updating. Is it connected to your network by wire?

Yes, connected by ethernet cable.

This isn’t a normal situation at all. To update a Uniti 2 you have to have both a physical lead between the USB port on a PC and the mini USB on the Uniti, and you have to have both the Uniti and the PC connected to a router so that both have an ip address. And you have to have the right USB driver, also you have to be running the update software on the PC. You can’t get to the situation where the Uniti says it’s being updated without doing all this.

So if a Uniti 2 is showing the update message without you doing the above, it’s got a fault.

Two things you could try, although whether they will work I don’t know. If the unit is responsive to the remote then you could try a factory reset. And you could try doing a firmware update as per the above procedure.

Otherwise you are going to need to get a dealer to send it back to Naim for repair.

Anyway good luck and do tell us how you get on.



You do it via the remote, select the wrench or spanner key and factory reset is a sub-option in one of the options presented. From memory it’s in system status or similar. It’s not hard to find.



Thanks David.
The Uniti 2 is indeed showing the message without the USB connection you mentioned.
And it’s not responding to the remote or the buttons on the unit itself at all, nor it has an IP adress at this moment (it did have before the update message suddenly appeared).
So I’m afraid I have to get it repaired… :unamused:

You could still try doing a firmware update yourself. You can’t actually “brick” a Uniti 2 by updating it, because it has basic fixed bootup firmware that will respond to the updating programme however many times you restart it.

But of course this still leaves the question of why is it in this state as you didn’t attempt to update it, so I do think a fault is most likely. But @NeilS (if he will forgive me interrupting his life again) may have another suggestion.

Anyway a Uniti 2 is well worth rescuing from it’s non-working state! It’s an excellent unit.



Thanks again David, appreciate it.

I tried to update it, with no result. The ethernet port also seems to be down (the statusleds are off), so the Uniti 2 is not connected to the network and has no ip adress. It’s also not visible in the router, it was before.
Hopefully NeilS has a solution for this!

This does sound odd Moony, so the message appears as soon as you power the unit on?

What happens if you power it up with the network cable disconnected?

It is a known state, but only if the unit receives a certain command via its IP address.

You could try a factory reset - switch the unit on with the front panel stop button held in until it prompts “factory reset”.


Thanks Neil.

Yes, the message appeared as soon as the unit starts.
It made no difference with or without the network cable, tried that.

I tried your factory reset this morning, the first time I got the message: ‘Factory reset, press mute to confirm’. Of course I pressed mute and the proces began. First resetting the Network settings, that went well, and after that resetting the streamer.
Unfortunately the unit was about 2 hours stuck in the proces " Please Wait, resetting streamer". If I try it again, the same happens.
Looks like the streamer module is defect?

Now what? Send it to Naim UK for repair? Or do they have repaircentre elsewehere?
Because I’m living in The Netherlands, and bought the unit 3 days ago in Germany (at a shop where they don’t sell new Naim, I assume this was a trade-in unit). Of course I will contact them also, but want to know what my options are.

If you only bought it a few days ago surely it comes with some warranty, if only a couple of months. I’d ask the shop either to give you your money back, or to arrange for it to go to Naim for repair, at their expense. If it goes to Naim it will be away for a long time. There may be a repair facility in the Netherlands, I’m not sure. But in any event you shouldn’t need to worry about it. The shop has a responsibility to sort it out.

I had very similar issues with my Uniti 1 when I bought mine. Naim will get you sorted out I am sure, and hopefully as the Halibut said, maybe where you bought it will help too. The Uniti 2 is fantastic, it will be worth it! Hang in there!

Yes, it definitely sounds like a failed streaming card.
I would contact the outlet who sold the unit at first.


Thanks all, I will contact the seller tomorrow.

I returned the unit and got my money back.
So no updates will follow. Thanks again all.

I am thinking about my options now.
Another s/h Naim unit? Or switch to active speakers with a decent streamer? Do I need active room correction?
Time will tell…