Uniti 2 upnp library problem

Hi everyone
First off, I have searched the forums and I am aware that library problems have been discussed but I can’t see a definitive answer anywhere.
I have the uniti 2 with my upnp library on a Innous zen mini mk 2
The problem is that the uniti is temperamental with the music library. It is often incomplete and I cannot find albums/artists that I know are on the innuos.
There does not seem to be a simple method to update/refresh the upnp library on the uniti 2 and I don’t know why it sometimes finds all the library and sometimes doesn’t…
I’ve refreshed the library on the zen and I’ve painstakingly gone through album/artist/genre etc etc on the uniti
One thing I have noticed is that there are several different music folders on the innuos so could this be ‘confusing’ the uniti?
I also have a Sonos system and this has no problem accessing all the music on the innuos
I am aware that Naim is suspect re it’s software as opposed to it’s amazing hardware but a streamer that doesn’t find all the music is not great
Any advice appreciated

Addendum: After my post, I did the usual technology solution i.e switch off the Uniti at the wall, wait a few minutes, then switch it back on again
The library is now fine again but…why should I need to do this? Why does the library fail to remain complete as time goes on?

Are you using an Apple device?

iPhone 11
Library seems spot on since rebooting the uniti :crossed_fingers:

Hi @singgs

The Uniti2 UPnP support is all server side driven (as are all upnp solutions), we just show the list of information that the upnp server returns back to us. I believe the Sonos indexes the server itself rather than use the upnp server, so it’s not comparing like with like.

Next time it fails I would suggest check a few things:

  • see if the products green front panel upnp browse shows the correct content.
  • see if the iphone app shows different content. Primarily the naim app on the phone privately browses direct to the upnp server, so doesn’t talk to the product for browsing.
  • check if its alphabetically cut off. Eg it shows A-S, but T-Z are missing.
  • if its impossible to scroll to the very bottom of the list as its waiting for the server to deliver more pages and they never arrive.

I’m suspecting there is some upnp server side cache that under some situations causes invalid views to be delivered to the app or product.

Best wishes

Steve Harris
Software Director
Naim Audio Ltd.

Hi Steve
Thanks for the response. I had already tried all the things that you suggest with no success. However, the reboot of the Uniti 2 appears to have worked.
I accept that this is an issue of the Uniti and the server not “talking” but there seems to be no way round this without a reboot which is disappointing.
It is massively less common for this problem to occur with my Sonos system which uses the same server.
I was hoping that there may be a Naim side fix to the problem but it appears not unfortunately
Kind regards

Thanks. That is clear

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.