Uniti Atom HE and Roon

My Uniti Atom HE has stopped showing album art when driven from Roon. Instead, the screen just shows ‘Chromecast Built In’.
Anyone got a fix?

1 Like

Sorry to reply to my own post, but I found that if I disable Chromecast, using the Naim app, Roon now displays the artwork.

1 Like

Makes no sense as you don’t use Chromecast for streaming Roon on Naim kit they are Roon Ready and that’s the zone you should enable . Having Chromecast enabled or disabled should make no difference to artwork as it’s a completely different input.

That’s fine, but I’m telling you what worked, which is all that interests me.
I didn’t want others to continue to puzzle over it, so as far as I am concerned the topic is closed satisfactorily.

1 Like

Within roon you would be able to “see” the atom as roon ready and as a chromecast endpoint, and also airplay; all selectable as zones so you might have been using roon > atom as a chromecast endpoint rather than as a roon ready endpoint.

1 Like

Thanks Robert, but within Roon I only see a single Atom HE icon, with no options for Chromecast or Airplay. Can you elaborate a little please?

Are you looking in the audio settings menu where you enable/disable your endpoints?

As Chris says, it’s in the settings menu. Roon would see all the possible endpoints in your house, and that includes the same device offering connection as roon ready or chromecast or airplay. If these are enabled then you could choose the “chromecast atom” or “roon ready atom” without noticing (unless you deliberately renamed them). Disabling chromecast via the Naim app would make it disappear within roon.

And that’s precisely what I did.