Uniti atom not working since Mu-Su update

It may be a coincidence but I’m not a great believer in such things. I got an android Mu-Su update today and it seemed to give me little choice but to accept it as it said I would not be able to get tidal to play - even though I’m a paying subscriber. It took an age but it is done. now the uniti atom is not recognised as being on the network! now I know it must be as it’s playing radio BOB through the muso it’s just not showing the uniti atom. using qobus or tidal or qobus apps independent of the naim app makes. another new development is that the uniti ataom is not displaying the radio station graphics. I have never really used the reomote control for anything other than volume control - not even changing sources all done via telephones - I have both android and apple iPhones - see previous posts for long and boring explanations as to why. suffice it to say I am dumb when it comes to anything but basic modern technology. just to make things more interesting I have zero short term memory!

Ensure you are running the latest version of the Naim App: 5.22.2 for your Apple devices and 2.22.1 for Android.

Fully power down your phone/tablet and back up again once you have updated.

Give that a whirl and we can go from there

1 Like

OK, done that and spent 10 minutes finding my SIM lock password! no change i can see - except the mu Sue is the only option and I am listening to radio bob but i see no graphics on the uniti atom. Back to basics - the name logo is lit up so I have presumed that’s a good sign. I have no other sources connected to naim so have no idea if everything else is working etc. NO CD player or connection cables even - those days have gone for me! Have a think I off out for 20-minute leg stretch for circulation

Hi Clare I’m one step ahead of your techs - I pulled out the mains plug on the atom went for that walk and came back and plugged it back in. miracle upon miracle it’s fine now and is doing all the necessary things as advertised. I’m expecting your job offer very soon ! I trust you will be discreet and keep this between us.

  1. List item

Same here, turned everything off including router and turned it all back on again and everything is there again!

Spoke to soon, devices keep going walk abouts……

All good since the reset. my stepsons who both work in IT have consistantly said you must pull out the mains plug and wait at least 20 seconds. are you taking about a uniti atom or a Mu-Su?
in the absence of any other support I dont think it can do any harm.

Indeed, that is the full power cycle advice we consistently give - totally unplug from mains power and allow the power to dissipate. We recommend at least 15-30 minutes, rather than seconds, due to the buffering systems we use.

Claire, are you suggested I need to turn all of my devices off for 20 minutes and then turn on again before the app will work as Naim intended.

I am having daily issues with devices going walk abouts and getting the wheel of death. Nothing has changed in my home network and everything was fine until the update.

Please advice as this is getting very frustrating given the investment I have made in Naim products.


Hi Gary,
I’m trying to share advice that I know has worked for others.
These are complex components, with a huge amount of digital interactions. Resetting the device with a power cycle - as described above - fully clears down anything that could be buffering and causing issues.
It’s not something you need to do very often - i’ve only ever done one on my Uniti Nova in 3 years - but I would recommend it.

In time, I would also recommend you log a call/email with the Naim Support team - support@naimaudio.com - so they can run a diagnostic and check all is working as it should, including your network.

Thanks Claire, do t want to come across shirty and a distinct possibility it’s “ user error!”

Given I have powered down and re started everything and still the devices don’t all show and keep dancing in and out I’ll book a call.

Appreciate it’s complex and lots of variables but boy it’s frustrating having c60k’s worth of hi fi and I can’t do simple things like play a song!

As I said before, it’s your network that’s playing up for sure.

But I can’t help any further because you haven’t given us any more information.

Hi David, when you say network what are you referring too - I can see 2 out of 4 devices predictably, one device dances in and out and one doesn’t show at all.

One is wired and the other three are wireless. One wired and one wireless work fine .

Standard sky Router, Cisco switch.

If all 4 didn’t work I too would conclude network.

I have powered down everything, deleted the app waiting a few hours and then reinstalled app and switched everything on again but get the same result as before.


Hi Gary

My experience is that the Naim app on iPhone or iPad always talks immediately to my Gen 1 Qb, two SuperUnitis, a 272, a Nova and a Core. If rarely something isn’t there in Rooms then a restart of the app sorts it out in a few seconds. I run all sorts of Naim betas and I don’t see problems that other beta users don’t see. It’s all very solid.

My network is a Virgin Media Superhub 2ac, with an Apple Extreme providing a second WiFi network and I use a chain of Netgear GS1** switches to give me Ethernet ports wherever I need them around the house.

It just always works and that is probably down to the router working properly most of the time.

Your Cisco switch should be ok, but I have heard odd issues with Sky routers and I don’t know what your devices are. If they are legacy Naim devices and you are using WiFi, that may be the issue. If they are modern units then WiFi should work fine. I’m not sure why your latest update is giving you a problem. But just saying “the last update messed it up” when almost everything (except the poor neglected Core) has been updated in the last month and everyone’s set up is different isn’t giving anyone much to work on.

Thanks David, probably just ignorance and frustration on my part - that said high end equipment should just work. I don’t think it was unreasonable to jump on the update as the root cause as it all worked seamlessly prior to that.

Going to have one more full shut down including router and deleting and reinstalling app and will restart it all tomorrow.

Having a rough week with covid in the house so a tad grumpy and I just want to play music……

Thanks for replying and if I can’t nail it will email Naim as per Claire’s advice.

Ignorance and frustration are allowed. We have had Covid in the family, albeit not in our home, this week too. So I understand.

Naim support is very busy at the moment so if you think that there may be anything I or other people here may be able to help with, do post again.

Good luck with the Naim kit and with the Covid.



1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.