Uniti Core Downloads folder is suddenly inaccessible

I have recently been struggling to get back to the cores downloads folder within Windows 10 explorer. I have made no changes to the network that its on. I had to place a laptop into the NAIM workgroup for this to initially work. I also tried other things like ensuring that network sharing was on, SMB enabled etc. Somehow today with the same network settings and laptop I am now unable to get back to the downloads folder. Has anyone else had an issue with this? And if so were you able to figure out the fix?

Have you tried entering the IP address directly into Explorer’s address bar? e.g. 192.168.1.xxx

That has worked for me when Windows is being recalcitrant.

How is it inaccessible, what’s the error message?

The other thing to try is restarting everything. With the Core, do it as a power off restart, not just using the front button.

Using the IP address as advised by @PW42 (and by Naim in their on-line support guide) is a sure fire way to get this to work as long as the Core hasn’t crashed , which is why I suggest a restart.