Uniti Core stopped saving new album artwork

I have not done that yet. But this seems like the next step. I’ve been wanting to take this slow as to do no harm. It has literally taken me years and a significant amount of patience to get to this point with my collection.

I"m still waiting to hear from support on this, but I’ll go this route over the weekend if nothing changes. Thank you again.

Ok another thing to check before you do. I am assuming you do have a backup? If not then it’s easy to plug a USB HDD into the front panel USB socket and backup to that. It will take a long time! Days not hours. But once you have a good backup, then you can always “Restore” (ie copy using the Core itself) the music back to the Core’s music store.

If you do have a backup, then I would suggest to just check that it is up to date by looking on a PC and seeing that your most recent rips and downloads are there.

You don’t need to have a backup before you do a factory reset, but that’s a bit like you don’t need to look at the lift floor before you step into it, but if for some reason the doors opened when the lift wasn’t there, you will be glad you did look first!

1 Like

Yes! I do have a backup. I would’ve lost a lot of sleep without it.

But it’s been a few weeks since it was updated. So I’ll do that first.

Thanks.

I seem to have the same issue.
Core rips fine. Album / track info’ all good, but no artwork.
When I do succeed in manually adding the album artwork it seems to work, but then doesn’t “stick”. Disappears again.

Yep. It’s weird when it disappears before your eyes. This was not an issue for me until just a few days ago. Baffled. And frustrated.

If you have time to play around, another thing you could try would be to put a USB stick or drive into the USB socket, then go into manage music and select the USB stick as your Music Store. Agree to format it, so it needs to be empty or with stuff you don’t mind being deleted on it. Now you could try ripping a CD and adding a download and see what happens to the cover art.

I think this will mean all the music on your internal drive won’t show up, unless you select it as a music share. You go back to the present situation by reselecting the internal drive as your Music Store. You could also then add that USB drive as a Music Share and see what changes with the artwork on the files you just put on it.

Thanks, David. I think my next action will be the factory reset as you suggested yesterday. It seems logical…safe…and relatively simple, thanks to your instructions!

I’m traveling for a couple of days, so this won’t happen until Monday at the earliest. I’ll let you know the results. Again, so appreciative of the advice and concern.

1 Like

UPDATE:

  1. Did a hard reset of the Uniti Core. That didn’t change anything.
  2. Did a “reset music database.” It took a bit of time to get moving, but after about 4 hours, it had re-indexed 1670 albums, all of them downloads. But at that point the process seems to have ground to a halt. It’s been at least 4 hours since I reached the 1670 level. That represents about 2/3 of my downloads, and about a third of the total number of albums that are stored on the NAS. I was encouraged by the degree the way the database seemed to be rebuilding, and as @davidhendon said above, there was a certain fascination in watching the count grow. Now the fascination has turned to frustration, as it makes no sense that the process has stopped for no apparent reason.

Any thoughts?

UPDATE 2:

Rebooting the Core seems to have opened the pipes once again. At least for now, the re-indexing continues.

Very interesting. Obviously a factory reset doesn’t kick off a re-index as I said would happen, so I was wrong about that.

Anyway the fact you had to restart the Core to get the indexing going again suggests to me that this is actually a network issue. I don’t think I had appreciated that your downloads were on a NAS rather than on the internal hard drive, not that that should make any difference. But it does bring question marks about the NAS firmware and settings into the picture.

I will be interested to know whether it indexed your whole collection properly and also whether the Core will rip a CD now without losing the artwork.

This has been quite a learning experience. I get what you say about network issues. That’s a very likely explanation.

When all was said and done, the entire NAS was re-indexed. The process took about 12 hours.

All of the CDs and downloads that were not showing artwork last week are now displaying them. So that’s great progress.

I have found one CD without artwork. In Finder, I can see the coverart file. So I don’t know why THAT one has refused to comply. But everything else seems fine.

The test will come when I try to upload a new downloaded album or try to rip another CD. I may wait a few days to do. I’ll keep you posted. Thanks for the words of support.

Hi nycjim,
I’ve just run into the same problem. Everything I ripped this week has no artwork but is otherwise fine (funnily enough it was also a cd boxset …). I was wondering if I’ve understood the trail of replies here but you need to re-index to get all back and working?
(I’m not quite in the same situation as you as the rips/downloads are on an internal hard drive but otherwise everything you write seems eerily familiar. I’ve done the switching everything off including router etc, and a factory reset but still not joy).
Cheers for any info.
All the best

I’ve found that if the resolution of the album artwork is too large, it will sometimes cause problems.

I’ve had album art that was around 3-4Mb, which apart from increasing substantially the amount of storage for each album (when embedded in FLAC files), also seemed to slow down the app (or in a couple of cases stopped the album from playing)

I try and help the artwork for albums at about 700x700 to 1000x1000 pixels, and U don’t have want problems

Yes. I went through a series of steps, all of which failed, including factory reset. Finally solution was using the Naim app to rebuild the music database. You can access that option in the “other settings” portion of the Uniti Core. For me it took many hours to rebuild the database. But in the end…it worked.

From my experience, 5mb is the limit. But that’s just what I’ve seen.

There is an actual number quoted by Nam, but I can never remember it, so I just remember 1000x1000 pixels.

But that’s for downloads. For rips the Core ought to be automatically resizing any image it finds that is too large.

Thanks for that, I’ll give it (the rebuild) a go this evening.
Like everyone else on this thread, I’d come to the conclusion that a max of 1000x1000 works well
Cheers

Good luck with the process. Hope it clears up the problem. This definitely seems like something that Naim needs to look at. It may not be happening to everyone, but it IS happening.

A quick album artwork update. The problems that I had experienced in late April were resolved with the “reset music database” process initiated through the app. It took many hours, but it worked and I was very relieved.

However, one small album artwork issue persists; and this seems like a bug that could easily be fixed. I have three albums whose titles begin with an # or a @ (and perhaps other character symbols) … among the #447 by Marshall Crenshaw and @#%&*! Smilers by Aimee Mann. Seems like this should be fixable by Naim.

1 Like

Ha ha,
I just logged in to comment on this to! After reading the posts on this topic, I did the reset music database and it fixed most the problems (with all the new rips) but then I started noticing that some of the older rips/uploads that originally had artwork had lost theirs, and this morning while listening to Godspeed You! Black Emperor - F# A# (Infinity) followed by Low & Dirty Three - In the Fish Tank #7 jumped to the same conclusion, symbols are the now the issue. Quick search through my library and every album with # in the title has no art work. Annoyingly, having noticed this I tried re-naming the album and then saving the artwork again (for a rip) and it doesn’t help. Amusingly, I thought I was so smart for noticing this … should have known someone would have got there sooner.

AS nycjim states, this should be a fixable error.