Uniti Nova - Set Time

First post - yesterday I finally became a Naim owner, getting a Uniti Nova to simplify my system and banish my ugly Cyrus boxes from the living room.

So far so good - I’m still exploring, and in doing so have discovered the clock button on the remote. This displays a time on the screen, which is exactly 5 hours behind BST. I checked the timezone setting and that’s set to London. I can’t seem to find any way to change the time.

Does a setting exist, or is it all supposed to be automatic and this is a FW bug?

Might be worth unplugging and replugging the mains…will force a reset.

I think it will take some time until the Nova is doing the time synchronization via Internet.

I had the same issue after the last update.

Time zone was correct but not the time.

Unplugging, replugging or reset had no effect.

I choosed and set another time zone and then revert to my time zone. And it worked

Aha! That’s fixed it, thank you Julien. I figured it was a timezone issue as the minutes were correct, only the hour was out.

I don’t plan on using it as a clock, but things like that bother me!

I can go back to rediscovering my old music now…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.