UnitiLite vs. 4.8 software release

I’m a modest Naim user with my UnitiLite playing mainly from Tidal HiFi build-in app.
As prior 4.8 soft wasn’t 100% ideal, now after upgrade to 4.8 is noticeable change for the worse. I’m not talking about sound quality but streaming and connection stability. I see nowadays “Cant Play” error or never-ending “initializing” indicator on the screen. Quite frequent device simply stop streaming after first or second track on the album.
As a result I’ve started to listening more from an internal cd, which imho is the worst part of the device (has already been serviced).
Don’t get me wrong, I’m delighted with this gear and it does great job along with my PMCs.
Although I’ve decided to mark the issue to Naim’s R&D.
Waiting for maintenance release 4.9 :slight_smile:

Try turning the Lite and your router off. Leave for a few minutes. Turn the router on and let it fully boot up. Then turn the Lite back on. Hopefully that will sort it out.

Hi Kris

Most probably no help, but I updated my Lite to 4.8 ages ago.

I’ve not experienced any issues with the app/unit as you describe.

Hopefully HH suggestion will help resolve for you.

Hi Kris,
I have a Unitilite too and experienced more or less the same issues after updating to 4.8. Did a factory reset on my uniti and router which solved the problem although sometimes still have some connection drop out which forces my to reconnect my connection between router and uniti.

I’ve already tried this, but I’ll do it once again.
In fact I’m not blaming eth connection, once it’s wired and IP address is fixed in my local RT.
Lately I’ve stopped using two different iPhones as remote controllers (I’ve always used the one closer to my hand) - this could be puzzling to the gear respond for two apps. With one phone not much changed, though.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.