Unitiserve 2TB issue (Internet Radio)

I have recently bought a Unitiserve 2TB second user from a Naim dealer. When it first arrived with me it was running version 1.7b software.

After familiarising myself with the device… ripping my first few albums, I tried using Internet Radio. On the iOS client I get the error ‘Internet offline?’ and via the web… "Internet Connection Problem’.

When connecting using Windows/OSX desktop client, I can see within the Unitiserve status that the device is mostly reporting no Internet access. Every now and then, when I click refresh on the Desktop Client Internet Accessible shows as True

After reading lots of threads on this forum I realised that; although working, the ‘slow’ ripping was the metadata search failures related to outdated links/services within version 1.7b.

I bought a copy of 1.7c (eBay) and have updated to 1.7c RC1 without issue. This has resolved my ripping metadata issues. Sadly, it has not made any difference to Internet Radio :frowning:

Any thoughts? advice?

Regards.

Well in short it does not have internet.

If your dealer is any good he/she would have insured that the device was reset in terms of DHCP, but perhaps on this occasions he/she forgot.

My guess is therefore its set to a fixed IP.

This of course assumes you are certain the ethernet cable you have plugged in is working and connected.

Assuming its working just fine then you need to download the naim IP tool. This only runs on PC, which needs to be on the same network as the serve. Make sure the serve is on and hooked up to your network,. Run the tool and hopefully it wil show up, select it and set it back to DHCP this should be staight foward to understand on the app.

Let us know how you got no.

garyi best me to it, but anyway I completely agree with his answer.

You could have got the updated firmware from Naim support for nothing by the way. That doesn’t help you now, but Naim don’t charge for updated firmware.

Best

David

Hi garyi,

It’s correctly picked up a DHCP address from my network. IP configuration is exactly as I’d expect. Internet connectivity is 100%. It’s successfully pulling metadata… but still no Internet Radio :frowning: I will have a look at the Naim IP tool, I haven’t used it so far.

davidhendon. Yes, I realise that now… my own fault for being too hasty! Lesson learned.

Is the Unitiserve still using that IP address that shows in your screenshots? That looks to me like a private IP address that can only be accessed on your local network, which might explain why you have no internet access. Looks like your router has a similar address, does it not use the more common addresses which normally start 192.168…?

Yes I’m thinking the same way as Chris. If it’s getting metadata for rips then it could be from the onboard version of FreedB although that is relatively limited in what is there. If the rips are of the old faithfuls, FreedB will probably have it, but if it’s an unusual and recent release, then it won’t.
Best

David

What I don’t understand is that the two odd IP addresses appear in both the screenshots, one with internet, the other without. I would certainly investigate the possibility that this stems from a static IP address having been set in the past, but why, then, is the fault intermittent, and why does the router also appear to have an odd IP address?
I remember when I first had a US, I occasionally saw similar behaviour, where the internet connection could be seen to come and go. I never did figure out why, other than that as I improved my home network setup, it stopped doing it. I certainly never used a static IP address.

Hi ChrisSU, davidhendon,

Those IP’s are no accident :slight_smile: They are one of my private LAN subnets. There is a Cisco firewall and DOCSIS router on the way out to the Internet. Network infrastructure (and how to penetrate it!) is my background.

My UnitiLite resides on the same DHCP served subnet, with identical IP config (obviously a unique IP) It has no issues with Internet Radio. Assuming my understanding of Internet Radio is correct - everything is client initiated so no port forwarding or open listening ports are required.

The album/artist/track metadata I can understand could be cached internally to a degree, but not the album cover artwork, which from time to time it is correctly picking.

When viewing the ripping monitor and system status messages using the desktop client, it suggests queries are successfully being processed over the Internet.

I am suspicious of some legacy config tainting matters somewhere, but I’m damned if I can find it!

It is odd that it’s flipping between true/false for Internet Accessible… anyone know the mechanism used to detect this? ICMP ping or something similar? I guess I shouldn’t be so lazy… wireshark would soon enlighten me.

I’ve connected to the console of the Unitiserve and behaviour is identical. There are no BIOS issues or any other faults reported that I can find.

Anyone happen to have the admin password for opening an RDP connection to the UnitiServe? I get the prompt… I have the means to circumvent that first line of security by resetting the password, but recovering the Naim set password is significantly more complicated. I’m hesitant of going in that direction in case I somehow upset hard-coded services running on the embedded XP OS… I really don’t want to corrupt the SQL DB of the now nearly 350 albums already ripped :grimacing:

I suspect you need Naim’s only remaining staff member who fully understands Unitiserve @Stevesky to help solve this one…

Best

David

Well I don’t know why you’re asking us lot, then! :open_mouth:

My gut feeling, before I started thinking about DHCP issues, was that this is the same (undiagnosed) issue that I used to see. Sometimes the network connection disappeared altogether, others, it would come and go every few seconds.
The missing artwork is an odd one, as it is stored with the album on the hard drive once downloaded, but it does seem that it fails to display when no internet connection is reported. Perhaps these dropouts also affect comms between the Unitiserve, streamer and apps as well as internet?

Hi davidhendon,

The Naim IPset tool is reporting my device as being configured for DHCP use. I’ve just put a call in to Naim seeking their assistance.

Fingers crossed :crossed_fingers:

Hi @user10110011 - May I call you 0xB3 for short…

I got a feeling this maybe an IPv6 issue getting in the way. I’ll do some sanity checks on an actual unit tomorrow based on your config and get back to you.

Best regards

Steve Harris
Software Director

Hi Stevesky,

You may indeed :wink: I did as requested earlier (by one of the very helpful Naim support staff) and switched from coax to fibre to recreate his working lab environment; which did some really quirky things!! including a DoS of my DAC-V1…

I didn’t take a photo of the other error, but it reported it was ‘unable to re clock’ and again made the DAC-V1 unresponsive.

After the third reboot of the DAC-V1, it connected over Fibre @ 44.1Khz but sounded awful, with clicking and all sorts of peculiar noise.

A reboot of the UnitiServe brought back stability, but coax/fibre makes no difference to my Internet Radio issue.

I’m finding that maybe 1 out of every 30 attempts at browsing Internet Radio brings up the ‘first’ hierarchical level of Internet Radio, the screen where Naim suggested is one of the options… selecting anything at this stage triggers the ‘Internet Not Connected’ cannot connect to Vtuner servers fault.

Let me know if there’s anything I can do my end to assist.

Regards.

The quieter you are, the more you hear (and learn) :wink: besides, nothing trumps past experience…

Hi @user10110011

Have investigated your issue and I think the problem is that your firewall is blocking access to some root domain servers, that Unitiserve uses to decide if there is internet present or not.

The system pings various root domain servers and if this is blocked then it will go into no external internet mode.

Address wise you will see pings on addresses like 193.0.14.129. The domain details are:

inetnum: 193.0.14.0 - 193.0.15.255
netname: RIPE-NCC-K-ROOT
descr: Subnet for k.root-servers.net
descr: See http://k.root-servers.org/ for details
country: NL

Overall ensure the server has free access to the internet on all ports, including ICMP.

I hope this helps

Best

Steve

Hi @Stevesky

All clients on the LAN have unrestricted access to the Internet IPv4.

I’m happy giving you remote access if taking a look yourself would help?

Regards.

Hi @user10110011

send me a message on steve.harris(at)naimaudio.com and lets setup a teamviewer session so I can log into the server. You’ve got me intrigued what it could be now.

Best

Steve