Unitiserve SSD / Sinologi NAS connection difficulties

Hiya - I hope someone can help me.

I am using a unitiserve SSD with a synology NAS.

I have had to re-build my NAS due to failed disks. I have copied WAV / FLAC files back (I had a full backup). So far so good I thought. I thought I was doing well as I remembered to go into the unitiserve app on my Mac and point the Unitiserve at the volume. The error I keep getting is “It was not possible to add the share \FLAC on host XXX. PingHost: SocketException - The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for.”

There was a suggestion on another topic that setting the Workgroup from its default to “Naim” would fix it - it didn’t.

I also tried to use the app on my iPhone which didn’t help me.

Obviously I can see the NAS from finder on my Mac - and I can see the Unitiserve using the IP address through Safari.

Does anyone have any idea what I have not done? Would be greatly appreciated if someone could help me out.



@ChrisSU can help you

Thank you … Hopefully will hear from him / her :slight_smile:

1 Like

Generally he responds. He is probably on travel or busy. Maybe @davidhendon , even if more specialised on the Core.

I am not the expert on the US SSD, but I think probably what you need to do is to establish a new share on the NAS and without even going into it, point the US at it at promote it to a Music Store, then you can move the files into the Music/MQ and Downloads folders within it. You will need to tell your US to reindex the music too.

I haven’t used the SSD version either, if @Adam.Zielinski is around he may have some ideas?

I haven’t seen that error message before, maybe worth calling Naim support. Back in the day you could just pick up the phone to Phil or Steve and they would sort it. I think there may still be one or two people at Naim who can help though.

Ideally I guess you want to restore from backup onto the replacement drive, but I’ve never needed to do this, or even come across any documentation from Naim about how it’s done.

What would work as an alternative is to create a new network share on the new drive and copy all your music onto it. Treat it like a downloads folder, in that you would probably have to use your Mac to edit metadata and artwork.
If you still rip CDs then create a new music store as well.

Good luck!!

Thanks both …

David - Yes done that. I have restored the files to the NAS. Thats all fine. The problem is when I point the Unitiserve at the new NAS volume - I get that error.

I also tried to rip a CD to see if it would create files - but that didn’t work either.

Okay - I think its a call to Naim next time I can - unless someone has seen this error.

1 Like

I don’t think you did do what I suggested, which is to promote the share to a store before you did anything to it. If the new location has anything in it at all, even an empty bin, then you can’t promote it to a store. Or at least I think that’s right.

Read what I wrote before. The order you do things is important.

David - thank you - okay I have managed to get the Unitiserve to actually see the volume. That was the first problem I was having. That was a permissions issue on the NAS - tracked that down. I now have a folder which I can use - which is empty - as you said I removed the recycle bin from it. I think a lot of this is down to technology and security has moved on - I forgot that when I rebuilt the NAS I had to heavily patch it - and with that I think has come many of the issues.

The new problem is I get a “Invalid Operation 'Cannot authenticate share …” when I am trying to promote the empty folder to being a “network store”. Any ideas on this? I strongly suspect its another issue on the NAS - I have made sure that the user has full read / write permissions.

I’m really beyond my knowledge here, but it sounds to me that the NAS isn’t responding to the US’s approaches in the enthusiastic way the US expects.

So I would be looking at permissions in the NAS.

The other thing which I’m not sure anyone has mentioned is that the US uses SMB1 to talk to the NAS. SMB1 is heavily deprecated these days for security reasons but notwithstanding that, there is no alternative because Windows XP which the US uses was never patched for SMB2 or 3 by Microsoft. Without SMB1 working in your NAS, your US will never talk to it at a more intimate level.

It’s quite likely that your NAS has the SMB1 service turned off and you may need to turn that on again. Incidentally Apple Macs can see everything because Apple haven’t switched SMB1 connectivity off.

Thank you for trying - I really appreciate it - I had looked at the SMB1 issue as I was aware of that - in fact that was pretty much the first thing I looked at.

Related - in case I cant get this to work - do you know if you can use a USB stick as a network store - if so - any idea what the maximum size might be? Windows XP is pretty dated (was actually thinking that updating the Unitiserve at some point might be a way forwards in the medium term).

Sorry but I don’t know the answer to that. I sold my US a couple of years ago after it had sat unused for a year or two since I bought my UnitiCore as soon as it was available.

I would give Naim support a call to discuss if I were you. At least @Stevesky still understands these old servers and maybe some others there do too.



Thanks David … I might take a leaf out of your book in due course.

i also use unitiserve with nas synology.
You need to enable SMB sharing on synology, also you need to enable ‘guest’ user read permissions on synology.
Music files must be in synology ‘music’ folder.
Once this is done with the Naim desktop client software, in the TOOL options you have to force the update of the shared folders

Thanks Ric - The first two I have done. Can you please elaborate on the comment “Music files must be in synology ‘music’ folder” please. Do you create a share called ‘music’ something else?

you need to install the ‘media server’ software package on synology nas. The application creates ‘music’ ‘video’ ‘photos’ shared folders. Then on synology nas - control panel - you need to enable ‘indexing service’
Unitiserve is defoult-enabled to search for music files in the ‘music’ folders of network devices.

When you have successfully set up synology nas, in the naim desktop client:

  • tool
  • scannable network shares
  • host scan
    unitiserve scans the music folders of all network devices, it may take several minutes.
    in the list you should see the synology nas music folder and the files directly in unitiserve music library

Thanks Ric - I’ll give that a try. Andrew

My US is not the SSD version so I could be missing something, but I’m struggling to understand why the Synology server needs to be enabled here. You need to put the music in a folder that’s accessible to the US of course, but running Synology’s basic UPnP server when the US has its own seems odd to me.

I didn’t in the past … in the past before I fixed the array and updated the disks and patched it was more. straight forward. However - what I am assuming here is this creates the folders etc with the right default names in it - which wasn’t required before. I have managed to get the Unitiserve to see the files and build a database out of them without installing this - but it wont write to it no matter what privileges I give the account.

I’ll try Ric’s suggestion and report back (I am now away from the hi-fi for an extended period) so will be a job in the new year.

I presume you have followed the steps in the manual for setting up a share and promoting it to music store status? On a Mac I find the ‘browser interface’ to be the only way to do this that works reliably.
Also have you correctly set up the folders on the NAS? There is a Naim document that describes this, which is very dated but probably still tells you what you need to do: