Unity Nova issue

My Nova has shut itself down and restarted for about the forth time in as many months. It only does it when I use the analog input with my TT. Is there any known issues when it has to perform A to D? It seems like its struggling as the volume control gets a bit laggy. Or have I got yet another faulty/unrelaible piece of Naim kit again? I must be cursed with Naim!
Anyone know anything regarding this?

Have you updated to the latest firmware?

No. Not at all. It should work flawlessly. So it does sound a bit like a fault, but it would be worth asking Naim Technical Support if they have any ideas.

No, I havnt checked. I will try tomorrow.

Hmm, I will call tomorrow but they may not be there until next week i guess…


Worth checking all the analogue connections are secure and I’d also check the analogue input sensitivity isn’t too low for the output of the turntable/phono stage in case there’s some kind of protective power down in the event of the input being too high or clipping.

Have you tried a different analogue input to see if it affects more than one?

I’d try turning it off and unplugging both the mains and speaker connections overnight and then starting it up again. If that fails, then a factory reset may be required.

1 Like

I think the sensitivity is ok as there is no great jump moving from the analog input back to streaming, the level is roughly the same.
Iv’e not tried a different input, i will do that today, but that will still mean its faulty :slightly_frowning_face:

1 Like

Tried turning off the mains. I will do a factory reset today, just need to find out how…
Problem is, I wont know if its fixed until it does it again, and if it is faulty if it goes back to Naim it may well not show the problem. Such a pain!

I’d try unplugging the mains, the TT and the speakers for half an hour or so, before doing a factory reset - let all the electrical connections discharge.

Is the TT grounded?

I will do it today, then a hard reset :+1:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.