Unremovable "Favourites"

Anybody else get this problem?

Sometimes an album that I’ve saved in the NAIM app becomes unusable and unremovable, probably due to a copyright issue or the like, I would imagine. If I go to my Qobuz app to load another available copy and delete the old one, it deletes from the Qobuz app “Favourites” list but doesn’t from the “Albums” NAIM" app list, where it stubbornly refuses to allow deletion, as in the two pairs here.

I had the same issue, but indeed deleting from the streaming app such as qobuz or tidal did the trick. Are they still there after you had closed the Naim app and restart it.


Just brainstorming:

  • Restart the streamer? (So it reloads from Qobuz?)
  • Log out of Qobuz in the Naim app, and log in again? (Might trigger a fresh sync as well; I don’t know, if there’s the risk to “loose” anything by this.)

There’s no opportunity to Log Out of the Q app in the NAIM app.

I’ve tried logging out of it on the app itself and tried reloading the NAIM app, all to no avail.

When I tap on one of the problem items, this is what I get.

You can logout of Qobuz in the Naim app by selecting input settings and then Qobuz.
This is in IOS at least.

Maybe cancelling the show favourites option and then re-enable it.

Would that delete everything in my list, though?

I doubt it. The option is “Include Qobuz favourites on home screen”. If you unselect that, why would the Naim app reach into the Qobuz system and delete them?

My thought is that when you select it again, the Naim app gets a new list from Qobuz, which wouldn’t include your deleted ones.

But I don’t know, as I don’t have that option selected myself.

Tried it. Weirdly, one has disappeared and the other hasn’t.

So I was half right! Did you try logging out of Qobuz in the Naim app?


Ok. So if you log into the Qobuz app and look in the list of favourites, does it show the deleted favourite still? If so then this is a Qobuz issue.

But if the Qobuz list is ok, then it’s a Naim issue. With the Naim app, if you delete it and then reinstall it, you delete all the data associated with the app, which will include any list of Qobuz favourites that the app has stored. So then when you sign into Qobuz in the Naim app, it should repopulate your Qobuz favourites onto your Naim app screen.

Well I suppose I could do that if these glitches occur more often but really, it’s yet another NAIM app irritation.

They still haven’t provided a sidebar slider for lists if you use Android so you have to swipe instead.

And “Qobuz” lists aren’t arranged in the same way between direct access and access via the NAIM app.

The app retains it’s traditional place as the worst part of the NAIM experience. :roll_eyes:

I’ve just removed a favourite by touching the three dots and choosing remove from favourites. It’s probably silly asking if you’ve tried that.

Might be worth going into settings on your mobile or tablet.
Go into naim and qobuz apps and clear cashe.

When I touch the dots, nothing happens except a brief “buffering” symbol.

Clearing the cache made no difference.

When I touch the dots I get this screen, which seems to be what you need. It’s with iOS mind you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.