Volume only adjustable in 5s playing Spotify on Uniti Nova

Just to reiterate don’t expect any responses from Apple directly - it’s a feedback portal for problems but they rarely respond directly, it does however alert the software teams to possible issues with Apple’s software.

Did the Spotify app change at all? If not I suspect Spotify is using some iOS software routines to detect or effect volume changes from GUI elements and if a difference has crept in at Apple’s end then the Spotify app is doing the same as ever just the Apple routine involved is either broken or behaving differently.

There is no sign of a Spotify update since 14 October, which is as far back as my list goes on the iPhone. I can’t remember one recently, but of course iOS was updated to 16 a couple of weeks ago, which is what seems to have caused this.

Apple seem to be rejecting Spotify app updates due to them wanting to include audiobooks!

I’m having the same issue. How about those of you who use Tidal connect, do you have this issue there as well?

I have the same issue with Tidal HiFi.

Yes, issue is there using Tidal Connect too

Hi everyone,
This morning I switched on my Atom and connected it as previously with the Spotify app.

To my surprise volume adjustment issue seems to be fixed now.
I can make volume adjustments as previously in single steps.

Seems apple, Spotify or who else fixed the bug…
It works out of a sudden :slight_smile:

Haven’t tried it with tidal etc

1 Like

No such luck with my Uniti Nova. Spotify updated 15 Nov and iOS 16.1.1 but it hasn’t made any difference. I can sometimes get single steps volume adjustment by connecting via Airplay first, then going direct to the Nova, but even that seems inconsistent.

Uuh sorry to hear that
I run it today again and it worked with single step adjustments …
That’s really annoying … especially in such a luxury device
I will keep an eye on mine to see if this is only a temporary solution or runs now normal

Hi all,

Unfortunately this is a bug/compliance issue that is on Apple and Spotify’s side.

As of iOS16 the way an app interacts with the ios volume control changed and this has had a lot of implications and has broken Spotify Connect on devices that expose 100 step volumes.

IOS via buttons exposes a very low resolution volume control - ok for a phone speaker that may pump out fractions of a watt, but not ideal to control a high powered Hifi.

From our side the Spotify library is provided in closed source form and even if we had the source it wouldn’t help - the issue is phone side.

A case of that Apple and Spotify need to sort out their differences.

With regards

Steve Harris
Software Director
Naim Audio Ltd.

2 Likes

Thanks for the sympathy StreamKing! It is indeed annoying - it’s putting me off using Spotify at all. Strange that it works ok with an Atom but not a Nova - does that make any sense?

Thanks for the clarification Steve. Is there any indication that Spotify / Apple even know about the issue? Has Naim reported it to them? I’ve reported to Apple, but of course you don’t receive any reply. Not sure how to contact Spotify.

It’s really hilarious….

After it worked on my iPhone 12 with iOS 16.1.1 to adjust the volume in single steps I decided to update my iPad from iOS 15… to iOS 16.1.1(20B101).

And now guess what happens…?

On the iPhone 12 its still possible to make the volume adjustment properly in single steps.

But the bloody iPad isn’t now working properly :laughing:
On the iPad I can adjust the volume with the Spotify app only 5 steps adjustment… jumps from
20 - 25 - 30…

A big applause to Apple, Spotify …
no idea how this is possible …. A kind of voodo

In addition to my post a minute ago…

Can you please try the following:

  1. Open your Spotify app
  2. Push the Spotify device select button
  3. Disconnect your device back to your iPhone / iPad
  4. Terminate Spotify app
  5. Open Spotify and select a song
  6. Reconnect with your Naim player

After I did this the iPad responds properly and the volume adjustment works now on my device in single steps (with the slider in the menu and buttons)

I don’t know if this might be a solution but this is what I did a few minutes ago on the iPad and now it works …

Well… I didn’t believe that was going to work, but it did! You may have hit on the solution here - at least a very useful workaround - thank you.

I’ll monitor for a few days and see if it continues to be the answer. Maybe it only works on Mondays (!). This technology is a mystery sometimes.

Happy to hear that my suggested workaround seems to solve the issue even if I don’t have a clue why this works…. :joy:

Seems to be a mystic Monday or so.
Next time I’m going to fold an Aluminium hat or so…

I hope it will work out for you and others here

All the best

Hi @StreamKing-STR

Once there is one control device that is connected to your Spotify account and is cursing the system with steps of 5, it can influence all the others.

Primarily the system volume gets distributed to all devices, but if one then rounds it to nearest Apple volume, it will then send that volume back out and hence then they all change again. It’s chaotic stuff.

Terminating the Spotify app (so go to open apps and swipe them so they are really closed, rather than in the background), then retesting can help give a bit of sanity to the situation.

Best

Steve

This for me has still not been resolved. I’m using Tidal, not Spotify and when using the remote or the wheel on Nova and Atom, the volume goes up, then jumps back down. It is impossible to use properly. It does not happen when either adjusting the volume in Tidal through Tidal Connect (only the increments in 5 issue there) or in the Tidal app. It also happens when listening to internet radio, so would suggest not a Tidal/Spotify issue. Restarted all devices many times.

The plot thickens! Internet radio works fine for me. Have you tried the Spotify suggestions above, i.e. shutting down Tidal and re-opening, as a workaround? This is still a solution for me, if not a proper fix.