Weird glitchy HDX/App communication issue

I have about 2,000 CDs ripped to a 2011 vintage HDX (non-SSD) with an attached Netgear ReadyNAS, all ethernet connected to the router. To access it I use Roon. It all works perfectly well.

But, although Roon (via a core running on a Nucleus, ethernet connected) can always ‘see’ and play files from both the HDX and the NAS, the Naim and N-Serve apps often cannot access the HDX. They can ‘see’ the box is connected, but the Naim app cannot list the albums. On the N-serve app, the ‘connection light’ on ‘Select Server’ in Settings is grey not green. Weirdly, on the Naim app I CAN see and play files from the NAS. Also weirdly, third party apps like MusicStreamer have no problem with the HDX (just like Roon has no issue). Nothing I do with the Naim apps makes a difference (refreshing cache, restarting, deleting app and reinstalling etc.)

So, in the past, I’ve just ‘solved’ the problem by soft powering down the HDX and restarting it - then everything is back to normal and has usually stayed that way for weeks. But recently the time between restarts has become a matter of a few days, not weeks.

Why bother posting this if Roon/HDX is working fine? First, because using N-serve is the only way I know of monitoring the HDX while it rips: not having it work is a bit of a pain. Second, because I’m mildly concerned that, if the problem is getting worse, there’s some underlying problem with the HDX that will reach a crisis and I’d prefer to head that off.

Obviously not urgent (since I can play music no problem) but curious as to whether anyone has any views on this.

Oh, I should mention that if I go to the product’s webpage (http://192.168.0.XX) when the Naim apps have a problem it is completely blank.

I use a HDX - though the SSD variant - with a ReadyNAS and have not had the problem you are having.

I mainly use the n-Serve app on my iPhone but are you using it on an iPad?

What version of firmware is the HDX running? The latest version is 1.7c. The n-Serve app can show you this if you go into Settings and scroll down or from the HDX front panel go Home>System>System Status and scroll to page 31 of 87.

You can monitor the ripping from the front panel screen if you go Home>System>Ripping Monitor.



The HDX firmware is 1.7c RC1. The IP address is reserved on DHCP.

I use N-serve app on iPad/iPhone and MacBook. All go ‘offline’ after a few days of being connected. Same with the Naim app. Sadly, I can’t use the front screen ‘cos I have the HDX version with no screen.

What’s curious about all this is the Roon connection to the HDX is completely solid - which is a good thing since, ripping aside, I always use Roon as the UI.

In the Settings section of the n-Serve app are controls for ‘auto connection’ and ‘stay connected’. Have you tried toggling those?

Have you recently made any changes to your network or added any new components?

If your HDX doesn’t have a front panel then it sounds like you have a NS01 (although perhaps the factory made a few screen-less HDX specials to order to use up parts?).



Yes. I’ve tried the connection toggles. No luck. The HDX is an actual HDX - in its first iteration 10 year or more ago you could choose a screen or no screen version and I preferred to drive it via app.

As for my network - no changes at all for the last three years. It’s a pretty rock solid Ubiquiti set up. What’s odd is that it’s just the Naim apps losing - part of - the connection, other apps are fine.

Well I’ve learnt something new (re. screen).

I wonder if it’s a networking issue.

Perhaps @Simon-in-Suffolk may be able to shed some light on this.



Possible. I’ve Net Analyzer’ed my network and I can’t see anything super obvious, but I’m not a professional on networks.

Sorry I am not familiar with the HDX and never owned one, so not clear how it works underneath the covers.

No worries. Thanks for responding anyway!

Probably the best bet is for you to contact Naim support ( and see if they can resolve the problem.

When I first got my HDX (back in 2011) I initially had some issues - they emailed me a file which I saved to a USB stick which was then plugged into the front socket so they could remotely ‘dial in’ and interrogate the unit.

Good luck and please do let us know how you get on.



@Simon-in-Suffolk thanks for replying

I’ll wait until it happens again (HDX/app connection currently behaving perfectly since last HDX reboot) and give them a shout while the apps are down. Thanks for your help! Stay well.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.