Weird problem with Google Home

This is almost certainly a Google problem, but as it involves a MuSo 2, I’m posting here as well. Maybe somebody’s run into this. Here’s what I sent to Google. The soundbar in question is a Muso 2, which is connected to my TV through HDMI.


How do I change the name of a Google home device without it reverting? Changing it within the app works for a short while, but generally within 48 hours it reverts to its prior name.

Specifically, I have a smart speaker, which among other things, works as a soundbar for my TV. I named it Soundbar. But when I say, Hey Google, play music on Soundbar," it doesn’t respond. So I changed the name to Bedroom Soundbar, and it responds to that - for a day or so. Then, all on its own, the name reverts to Soundbar.

I’ve tried deleting the device and adding it back with the new name, changing rooms, and doing a reset on the soundbar. Nothing works.

We take it you’ve tried restarting the device on which you are running the Google app?

If that doesn’t work,
Ensure you are connected to the Internet.
Shut down ALL devices with the Google app and all Google linked / controlled devices.
Then start ONE device with Google app and then restart the Muso.
Rename the Muso.
Wait 15 minutes before restarting other devices that have the Google app running on them (this may need longer - we don’t know enough about Google’s servers!)

1 Like

When you say shut down, I assume you mean deleting them from the app.
Will try when I have the opportunity. I have a lot of devices, so restarting and relinking them will take some time. Moreover as the name reversion doesn’t occur immediately, it could be several days before I can declare success.

Probably not necessary to delete it from the app, just power the device off so that the record on Google’s servers is updated by the one Google app that’s running and there are no conflicts. Then the others should pick up the new name when they restart.

If this doesn’t work you may need to remove it from all the instances of Google controllers and then reinstall it.

1 Like

Nothing yet to report, as I have a name - Soundbar Muso - that has stuck for 24 hours, and I’m keeping my fingers crossed.

However, on the Google forum, I am told it’s a bug with the Naim software or firmware - that’s what causing the name to revert.

Soundbar Muso now has the record for the longest time without reverting. I’m beginning to believe it will hold.

Edit - it just reverted. I’ve opened a ticket with Google. I’ll wait to see it they have any recommendations.

Still waiting to hear from Google. But this morning, I tried the following:

  • I deleted the Muso from Google Home
  • Did a factory reset on the Muso giving it the name Naim Muso.
  • Tried running the Add Device in Google Home (three times). Nothing found.
  • Rebooted my iPhone. Now Google Home listed the Naim Muso without a room
  • Assigned a Room to it
  • And voila the Naim Muso was renamed Soundbar in both the Naim app and Google Home.

I’ll hold off trying Xanthe’s suggestion a little longer in the hope of hearing from Google tech support.

Go figure.

So - problem not solved but mooted (apparently):

This all began when I named my Muso 2 “Soundbar,” and discovered that, “Hey Google, play music on Soundbar,” did not work. (The music played on the Nest device receiving the command.)

But when I experimented, I discovered that even with the Muso named Soundbar, if I say, “Hey Google, play music on Muso Soundbar,” it will play the music on the Muso.

Hopefully that will remain the case, and we’ll all live happily and musically ever after.

1 Like

Google has acknowledged a bug. Maybe someday, they’ll have a fix. In the meanwhile I’ll just stay with my workaround .