Aaaand.....it's gone! The NDX connection to the network that is..again

And it’s getting worse and worse.

My setup consists of NDX 1 / 282/250DR/HICAP, all bought new between 5 and 7 years ago. Worked fine, happy with the sound, especially in combination with the detailled, precise sound of the Wilson Benesch Vectors.
I can’t exactly remember when the disconnect started. Suddenly the music stopped, had to reconnect, sometimes restart, annoying but not a huge issue. Or at least, not enough to really want to investigate or do someting about it. And to be fair, last couple of years I only occasionally seriously listen to music, most of the time it’s just background internet radio. But now the disconnects occur so often that it’s even frustrating with background music only.

Two years ago the display of the NDX broke down. Was replaced at the official importer (dealer is no longer in business).

Now, what do I mean with “disconnect?” The NDX seems to loose connection to the network. There’s no way to reach the NDX, the app is non responsive (either shows “there’s another device connected” or “sorry, we’re having trouble finding devices on your network”), I can’t ping it etc.
And to get the NDX back to life either a hard restart of the NDX or a input selection → P1 tuning or P5 error code → restoring connection → press play (internet radio) will restore the music.

Again, the number of disconnects is getting higher over time.

Browsing through topics I see that I’m not the only one, I see similar issues and many immediately pointing towards the network. It has to be the network!
Which I’m familiar with (working for the largest manufacturer of networking kit in the world). And we also know that it’s in almost all cases not the networks fault.

Anyway, for reference, the internet (cable) modem is the COMPAL CBN CH7465LG-LC, which handles the DHCP duties, the built in switch is connected to a Meraki MS220-8P switch, and the NDX is connected with a Cat6 cable to this Meraki switch. Furthermore there are 3 Meraki MR33/MR30H AP’s , but as the NDX is Ethernet connected that 's less relevant. Connecting the NDX directly to the built in swith of the Compal has the same result.

I deliberately keep it as simple as possible, both networking as my wording (and off course I ran all tool I have at hand…).

What to do?

1 Like

Forgot one thing: I did a factory reset. What I notice is that the NDX was very responsive afterwards. This was short lived however, and after a couple of hours it became clear the connectivity issues were still there.

1 Like

Do any of the meraki ap units have dhcp running?

Does the disconnection also happen when you are streaming local files?

Does allocating a static IP have any effect?

One VLAN, one DHCP server in the entire network, static IP address has the same effect (I do have a range reserved for ESP32 based devices, so tried that). Streaming local files from a NAS have stopped also, haven’t used it in a while.

This happens frequently to both my Muso and Muso Qb - I just put it down to being a Naim thing. No other device on my network behaves like that.

A power cycle always cures it for me.

If this happens once a week, I can live with it. But now it’s somewhere between 10 min and 4hrs min and that’s simply annoying.

Have you tried a different Ethernet cable, in case it’s been pinched somewhere? Also trying a separate Ethernet socket on your router?

As mentioned, I’ve even connected to the built in switch in the modem directly. And for the cable, the cables are tested and working just fine.
Also, maybe also good to mention is that Meraki is not exactly shabby low end stuff either and that there’s some built in tooling to see what’s going on in the network.

That doens’t mean that everything will always work. For example, there’s a nasty issue with the ESP8266/ESP32 WiFi chip with Meraki and DHCP ((not Meraki’s own DHCP, also using modem DHCP, seems to be ARP request related), which can be easily avoided using fixed IP addresses.

Naim seems to use APM components though. And caracteristics are different.

BTW, there’s two types of issues here:

  1. NDX completely dissapearing from the network: music cuts out, not able to ping, app can’t see the NDX, need to manually interfere
  2. Music or stream stops: still can see the NDX in the network, can ping, can reconnect stream in app or re-initialize input on the NDX (or press play) itself.

Anyone with the same issue and if so, what was the solution?

have you tried wifi to eliminate possible network issues? i know the mk 1 NDX is very limited but might be worth trying - also have you power-cycled router etc and phone/tablet at same time as NDX that has solved my problems in the past

I think you should try to eliminate as much of your network as possible to identify if you have an NDX issue. If you can I would try and have just your Music Server and the NDX plugged into a dumb/unmanaged switch (nothing else connected, no internet etc) and see if you still have same problem. I would control playback via the front buttons on the NDX so no control device needed either. You could also just use a cross-over cable between your server and NDX so no switch at all.

So all you should have on the network is Music Server and NDX (with static IPs)…if the NDX still drops out then I would say you have a NDX problem, if not, it’s something in your network.

If you have a local/friendly dealer perhaps you could borrow another streamer and see if you have the same problem. BTW what is your Music Server?