AirPlay and Uniti Atom?

Hello all !

I’m using an uniti atom (3.3.0) with iPad and iPhone iOS 13.
None is able to stream directly, using Airplay, music on Apple Music to uniti. I can see thé uniti in the list, but clicking on the device makes an error « unable to connect to uniti atom »

Any idea ?

1 Like

Did it work before?
(And if yes: has anything changed in your setup/network?)

If it did not work yet:
Seems devices are on the same network, otherwise they would not discover the Atom.
Can you reliable stream other protocols to/from the Atom? (Like Internet radio?) -> If not, your Atom might have a shaky network connection. (Which should only happen with WiFi, not with cabled connections.)
Otherwise it’s a repeated suggestion here, to restart Uniti and any switches/routers on the network and try again.

Hello Philipp, thank you for your answer.

1.It has never worked before.
2.Atom works with all other protocoles: Upnp with Mconnect, Spotify connect, awfull google chromecast, internet radios direct from Naim app…
3. I will restart all devices tomorrow, as suggested, but i’m sure it has been done before.
Could it be a name of the device problem ? I’ve changed it at the beginning.

Dumb question but you have enabled the Airplay input on the Atom in the Naim App?

Seems as if I am having similar problems but with Amazon HD via airplay2 from my Atom and losing the stream as if it is “buffering” .
This is followed by an error message window opening stating “streamer not responding” and then Uniti atom has to be reinstated on the Naim app on IOS. after it “cannot find room” and requesting I restart search for the atom.
Any clues?
By the way I forgot to mention that the Atom is Ethernet wired !!

@Gipsy, I think there is no dumb question, I verified and Yes, Airplay is enabled.

@Philipp, all rebooted, Amp, internet Box, Ipad, Iphone, Ibread (!)

@All: the real message on the phone is "impossible to connect “uniti Atom 666”

As I understand it, AmazonHD will be streamed wirelessly to your phone, then back to your network via AirPlay to go to the Atom. So although your Atom is wired, the signal still has at least two wireless legs to reach it. Compare this to Tidal controlled on the Naim app, or Chromecast, which both send the signal direct to the end device, and that could be your problem.

This is what confuses me as the IPad performs flawlessly with the AmazonHD app and does not suffer any dropout / “buffering symptoms”, (as you point out it is utilising WiFi to obtain the stream from Amazon music ).
It just has problems wirelessly from iPad to Atom via AirPlay .
The only assumptions I have is that it seems to have started in the last couple of weeks and tenuously be connected to the software update although I doubt that to be honest.

The Number of the Beast :latin_cross:


Problem solved, my internet box is not compatible with airplay. :frowning_face:

no you’re wrong, I have the same internet Box as you (LiveBox 3) and I can send music from my iPhone to my Mu-So with Airplay :wink:

AirPlay works within your LAN, and I’m not convinced that your ‘internet box’ needs to be compatible with it. I suspect the problem lies elsewhere.

i am having a similar problem. The airplay and chromecast stuff used to work beautifully. now, not so much. Tons of buffering. weird dropouts. Especially with certain sources (eg siriusxm app). I wrote to Naim about it, but they sort of blew me off, which was disappointing. but yeah, airplay and chromecast have not been working properly for me for quite some time.

I’ve found all versions of iOS13 pretty buggy for the music app and Airplay, so it may be an iOS13 issue. I’ve had drop outs, freezing, and non connections with my car player and Apple TV’s, I don’t use it for my Naim streamers though.

Airplay didn’t work with ios 12 neither.

What i tried today is to connect the streamer only by Wifi, then put static adresses for all devices, restart all appliances and no changes…

Hi, I have a similar setup and we ran into the same problem. The Naim Atom was visible as Airplay device, but it was impossible to connect. My wife mentioned this a few weeks ago for the first time and today my son was also unable to connect. I have unplugged the Atom for some time and connected the mains again. After a few minutes I tried again and now it works correctly. But I am pretty sure you tried this already?!

BTW: our Atom is connected via Ethernet.

Hi same problem here. I have a brand new atom since yesteday (but the remote was already paired, should it be?), everything work (chromcast, internet radio…) except the airplay connection: i can see the atom in the airplay list on my iphone, my macbook, but can’t connect to it, got an error message. I’ve try everything: power cycle, factory reset, ethernet or wifi, disabling all others wifi device in my home, swaping the router with another brand but nothing work. Never had this kind of problem with airplay before. My sonos beam was so easy to set up in comparaison, airplay just work every time i need .
Please Naim help us

I never use Airplay in general, so I just thought I’d just give it a go with my Muso QB2 and, like you, it does not work.
I’m using an iPhone6s running iOS 13.3 and my Muso QB2 is running firmware and app version 5.14.4
If my Muso is playing iRadio, when I try to connect Airplay from my phone, the phone appears to show it has connected (after several attempts) but iRadio is actually still playing. If I hit “Pause” on the iPhone, iRadio stops playing on the QB2.
I believe there is a firmware or App glitch.

You should contact Naim support directly or via your dealer if you are having problems. They may not pick up on issue posted here.

Best to contact Naim support if you haven’t already done so.

1 Like