Anyone’s NDS work perfectly?

Hi, I’m one of the people on this forum who have, for many years, had ongoing issues with their NDS when using Tidal, where it will stop playing or disappear from the Naim App
So, I’d be interested to hear from those who’s NDS works perfectly. Can you tell me
What device do you use to control it (iPad or Android Tablet and which one)
How is your NDS connected (WiFi or Ethernet)
Broadband provider
WiFi Router or Ethernet Switch

Some of this info may help to identify why I have problems and where that problem may be device, NDS firmware, network or broadband

Thanks

I don’t have an NDS but please would you clarify if this problem is only on Tidal? Does internet radio and upnp streaming work reliably? And finally, which firmware version is the NDS using? It needs to be 4.8.

When we had a 272 it randomly disappeared from the naim app. Device was connected via Ethernet. We see the same symptoms with our SuperUniti on WiFi, although since we almost exclusively use it for Tidal Connect now it hardly matters.

Posters here consistently point fingers at people’s home networks - and did so with ours. The network was perfect.

What I found was that when the device disappeared from the app, it could be restored by accessing the 272’s inbuilt HTTP website from the same device using the naim app. The device would magically then appear in the naim app again.

This pointed to an IP stack or firmware issue on the 272. I had some wire shark captures which proved what was going on (device didn’t respond to discovery) but then we sold our 272 and I lost interest.

My NDS now works very well, using it as DAC only.

Anyhow, I had a long term problem which I thought was just with NDS but when I got my ND5XS2 to use as streaming transport into NDS as DAC I decided to take out the Cisco switch. Since I have taken that out I have had no problems.

So effectively it was a network problem for around 4 years or more!

And it could just have been a case of resetting the switch. Since then, I am not putting it back in. It all works well and I am leaving well alone!

1 Like

Never had a problem with my NDS and owned since they were first introduced. Initially I used Asset and the Naim app without issues. I do recall some Tidal related issues in the early days to do with buffering if I remember correctly, however, I don’t use Tidal anymore. In recent years I’ve been using Roon with Qobuz and the NDS has worked seamlessly.

I’ve always had the NDS connected via Ethernet. As per HH be useful to understand if your issue is just Tidal related

My nds works like a champ but i use Audirvana to control everything, honestly its brilliant but you do need a computer in your house and a smartphone to controll it.

I use Qobuz with my nds now. before i did have some issues with the naim app but that was down to my phone (running the naim app) changing from 2.4ghz to 5ghz randomly, if you have a bt router then switch off one of those

Hi, it is running the latest firmware (4.8)
I don’t use internet radio often, other than to bring the NDS back to like as above. UPnP runs fine, with no glitches
There are a number of threads on here suggesting fixes, but ok trying to find a consistent working baseline from other users
Thanks

Thanks,
I can work around the problem, but I’m trying to make it reliable for my wife, she still thinks I should have never sold my CDS3, and there problems means she now rarely uses the NDS

Thanks. I’ve been checking and my although the NDS stopped working again today, my iPad has been consistently running on 5ghz

But you shouldn’t need to work around the problem, the thing should just work. Hopefully you will get some ideas. I was hoping you were on old firmware but that is not the case. I wonder if your router is somehow blocking Tidal, with a firewall or something. I’m not technical, but I wonder if @Simon-in-Suffolk has any ideas. He understands router stuff.

My NDS works perfectly on UPNP. I tried Tidal several times ( 1 month each time) and I had to restart regularly the Nds or the App. But as the sound quality is clearly inferior vs streaming from my Melco, or USB stick, I don’t bother.

1 Like

I’ve had an NDS for 5 years now. It has never been used under ideal conditions : a move to France, rented home, building a new house, duff internet connection, duff wifi within the 4 walls. There have been continual problems with using Tidal: the usual suspects (NDS disappearing from the app, dropouts). Netgear Nighthawk routers and extenders all playing havoc. About 6 weeks ago we finally got fibre cable installed to the house which has a cabled LAN. Rate via the cable is 1.6Gbs! The NDS is linked via a Netgear GS308v2/Chord cat6 to the LAN which goes back to the Orange Livebox 6 modem /router. Linking the LAN to the Livebox was a rogue Cat 5 cable whilst I awaited delivery of a cat 6. With this hardware the system still presented many problems : NDS and Core disappearing from the app, repeated reboots required, no iRadio, no uPnP. I was looking at having to find another £10k for an ND555 ( presumably via another of Pete’s « deals « ) with modern tech despite being happy with the sq of the NDS.
The Cat 6 arrived and was installed: the system now works perfectly. The app is on an iPhone SE 2nd gen. In 6 weeks no dropouts, no products disappearing from the app. Tidal works perfectly.
Conclusion : it was very surprising that a cat5 should have had such a detrimental effect. (Perhaps the cable was damaged…). Keep it simple with an all wire setup.
I hope this can help you: I was close to giving up.
Al

1 Like

when i checked mine it was all over the place, everyones network seems to be different though

i would look into using Upnp, like i say using Audirvana has worked out for me, i did the month trial then purchased a year, its not expensive

Thanks Nigel … I think…
@dannyf355 well there are lots of considerations.
Are you using iOS or Android… the former tends to behave better.
Are you using normal switches and what is tour wifi?
Some WiFi interoperates better than others… if you can does your router/wifi support IGMP snooping… if so try toggling it.

Another happy Audirvāna + NDS user here :+1: I believe the native implementation is living in the edge so offloading it with Audirvāna and upnp seem to solve stability issues and also provide better sound quality.

Cat5e and Cat 6 are very similar… if there a noticeable difference, it’s more likely to do with cable construction style rather than Cat type… and suggests there might be other issues at play if the ‘audio’ sounds different.

1 Like

Sorry Simon, though I know you love this stuff!! Your post reminded me of IGMP snooping; I have a new router, a Netgear Nighthawk RAXE300, and have been burrowing around in its menus, but it doesn’t seem to have the snooping. Netgear’s managed switches have it, but not it seems the Nighthawk. I’ve had so much trouble with mesh systems and Naim boxes vanishing that I’ve reverted to a simple single router setup. Three mesh systems have caused me problems so I’m hoping this simpler setup causes fewer problems. And ideally, no problems.

So do you have an issue at the moment with your new simplified setup?

The legacy streamers are just a PITA and require work arounds to get them to function at their best. The NDS is the best sounding legacy streamer for me but I opted to stay with my 272 b/c of the problems with legacy streaming. Using Tidal/Qobuz can be hit or miss. A big reason I dropped Tidal and went to Qobuz is b/c Tidal changed up their oauth login and it just buggered up my use of Tidal, couldn’t get it to login properly. Qobuz worked mostly flawlessly with my bubblesoft container work around. The room dropping from the app started with the latest firmware release. No issues prior to that. I just unplug the streamer from the network and reconnect to resolve. Annoying.

Not at the moment…

1 Like