App can't 'see' or doesn't show tracks stored in Downloads folder

#42

I’ve tried again, and no luck - the variable, so far, appears to be the off board vs onboard storage as manipulating MQ files or reading the download folder from a NAS may not have the same restrictions that the Core does - could it be that because the files were not directly imported from one Naim device to another but used the MacBook as the middleman, the Core chooses, a bit like the body after a transplant, that it rejects the files as unoriginal - this could be a DRM restriction that native recording and playback circumvents??? i’m spitballing now…

0 Likes

#43

If anything this might be down to how the Core treats its internal Store and external Store (i.e. NAS). But it seems unlikely, as both internal and external should have the same priority level.

I will just take out the files from RIP and move them to DOWNLOAD - let’s see what happens.

As to using MacBook as conduit - nope. Remember - you’ve sent me files, I kept them on my MacBook, added them manually and they work.

0 Likes

#44

Test completed - the files play equally well in the DOWNLOAD folder.
It helped forcing my UnitiServe to re-scan the Download folder for them to be picked up quicker.

Is that something you could do with your Core - foresee it to re-scan?

The exact structure of what I have placed on my NAS is different to what you’ve sent me though:
It has to look like this - please see the screenshot.
I did no other modifications to the files you’ve sent me - just placed them in folders.

They play fine - no problems.

0 Likes

#45

Hi Adam, i can transfer exactly like this to the downloads folder as below…but…

the app can’t see the tracks, even after re-scan / music database rebuild but, like i say, this is not with all albums

0 Likes

#46

but it is with an awful lot of the albums previously ripped on the old US…

0 Likes

#47

I think it’s time for some Naim support help. I don’t know Core well enough to help out, I’m afraid.

0 Likes

#48

Thanks for trying Adam, will do,

0 Likes

#49

In the Core the distinction between the Music Store (which is usually but doesn’t have to be the internal disc) and Musuc Shares. The point about the Music Store is that this is the place where the Core stores it’s own rips, in the music/MQ folder. There is also a downloads folder but you can put disnliads anywhere that you have defined in setup as a Music Share.

Naim stop you from writing to the music/MQ folder of the Music Store and you are only allowed to edit it with the app. There is nothing to stop you from copying an album from the Music Store, deleting it from the store with the app and then adding it with any changes you want into the downloads folder or any music share.

If you want the Core to index a folder which is somewhere other than in the Music Store or the download folder associated with the Store, you have to define the location as a share.

This is all basically the same as with the US, but I suspect you can get away with more things with the US-SSD which by its nature has to give the user more control. (Eg letting you tell it to store rips in a folder with a different name -RIPS/MQ).
Best

David

0 Likes

#50

Ok, so no change but i’ll contact Naim tech support in the next week or so (busy week at work), and let you know the outcome. thanks all for your help.

0 Likes

#51

Peez, did you look in “U” for “Unknown” like I mentioned? Whenever I have stuck something into the DL folder or MQ and it didn’t show up in the right place within the app, it would invariably appear as “Unknown”. IF you reformat these files as FLAC and put them in the Download folder, I bet they will finally correctly appear in the app.

0 Likes

#52

Close to cracking this - will report back soon

0 Likes

#53

OK, so, i have worked out that there is an xml file in each ripped folder that is preventing the tracks from displaying - move the folder to downloads and manually remove the xml file and bingo, they appear…in their ripped WAV format…thanks everyone for your help - very much appreciated

1 Like

closed #54

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

0 Likes