App is very slow to find rooms when changing access point

I currently have a router and, in a separate room, a wireless access point connected to the router via a TP-link powerline.

When I use the wireless access point, the app finds the rooms (Core, Nova, Qb) immediately. However when I switch to the router, the app will usually find the Qb immediately but it can be up to 15 minutes before it finds the Core or Nova.

This is the same whether using the app on my phone or on my tablet. Swiping down makes no difference.

System: Router is a BT Homehub 6. The Nova and Core are ethernet cable connected to the router via a Cisco 2960 switch. The Qb is connected via wireless (it uses the router’s wireless). The router’s 2.4Ghz and 5Ghz channels are fixed. I manually switch the device wifi to ensure it is not hanging on to a weak signal.

So it would seem to be something to do with the wireless from the router that delays picking up the Nova and Core.

Any ideas as to what I need to change to get it to pick the Nova and Core up promptly?

The answer you probably don’t want to hear is that ditching the powerline and running an Ethernet cable to the room where your QB is located should get things running properly. If it’s running properly, you shouldn’t need to manually select a wireless channel, I find that automatic selection usually chooses a suitable channel.

I’ve noticed since the FW upgrade my Nova regularly wont appear on the App on both phone and ipad, have done the usual reset etc etc. Hardwired router to 2960 to Nova.

I had the same problems, but after the factory reset AND in the App (settings), no more problems.
My recommendation for the topic above is to check the WLAN speed. I can control that very comfortable in my FritzBox! (Mesh view). It has nothing to do with the Naim device.

Agree with Chris, ditch the TP-Link Powerline.
A mate installed a wireless extender & hooked it up over an EoP adaptor on a temporary basis & he found it slow & clunky. He’s finally installed an ethernet link & its all OK.

Just to be clear the Powerline extender and Qb are working absolutely fine. It is the wap at the end of the Powerline that picks up the rooms instantly. And the wireless on the Qb is rock solid; no problems at all.

@ChrisSu: Thanks. The wireless channels are fixed for a separate reason but the same issue occurs when on auto selection.

@Hollow, @Pomito: Thanks. For me, this issue was present pre FW upgrade. Have tried resets of router, Nova, Core and app but no joy. Wireless strength is very strong and speed is 144 Mbps.

144 Mbit/s is not strong because of fluctuation (you ever have different Speed over the time) and can go to ZERO or very low !! and then the connection is disconnected. I have more or less 300 - 800 Mbit/s for all devices in WLAN depend on the WLAN Adapter of the device. The WLAN adapter of the Nova is very strong (okay is not connected via WLAN). My recommendation is to check the speed several times during the day. Also for me your Network is inherent, so many different devices which may interconnect not well. I would replace the Home (Standard) Router for a better one (e. g. TP-link).

I meant signal strength

I feel I have not explained myself very clearly.

I have absolutely no problem with the performance of any part of the system. The Nova, Core and Qb all work absolutely fine. I am loathe to change the router as it is actually quite a respectable unit for an ISP supplied product and I don’t want to disrupt the rest of the system (and it is not such a big issue as to warrant undergoing a significant change).

The only problem I have is that the app is very slow to pick up the presence of the Core and Nova when switching to the router’s wireless. The app finds them immediately if no other access point has been used since the previous use; it finds them immediately when using the “satellite” access point (which is of course fed by the router) but the app never* finds them immediately when switching back to the router’s wireless even though it finds the Qb immediately.

*which is why I don’t think it is fluctuating connection speeds.

After similar problems including not being able to add radio stations, deleting and reinstalling the app did the trick.

I use the IOS app to find six rooms including a Core, a Qb, a 272 and some legacy streamers and I have a WAP and a WiFi Router, the WAP being connected to the router by ethernet.

My iPhone often takes longer to find the Core if it has changed WiFi source since it was last used. Swiping down sometimes brings the Core back immediately, but if not then stopping the app (by swiping upwards in the active app screen) and reselecting the app always brings all the rooms back within a couple of seconds.

I have never found it necessary to uninstall and reinstall the app to get things to work.

I had already tried a reinstallation. I have tried stopping and/or exiting the app and restarting but it doesn’t make any difference. It just finds the Core and Nova when it’s ready to! (BTW, in case it makes a difference, these are Android devices).

It’s weird but maybe I just have to live with it.

@PW42, I have been through a similar experience, which I have now fixed, and one thing in your post really jumped out at me: you are using a BT HH6. That was the source of all my problems.

Background: my home has full ethernet wiring and I run a second access point to reach the part of the house furthest from the router. On acquiring the HH6 some time ago, I ditched it almost immediately as I noticed discovery issues with my Linn streamers and my Kodi media players. I replaced the HH6 with an Apple Airport which worked perfectly in terms of transition between APs (though other things about the Airport I did not like). Recently the Apple router died and I put the HH6 back in, hoping that a new firmware update might resolve the problems I’d had before. It did not. I noticed that when transferring to the satellite AP, I could immediately discover everything on the network from relevant iOS apps, but on transferring back to the HH6, discovery was a lottery. Sometimes immediate, but usually about 15mins later.

By coincidence, I recently acquired a BT Smarthub 2. And all my discovery issues are gone - it just plays nicely with the rest of the network. Transition between AP’s is faultless in both directions. The Smarthub 2 seems to be a much more capable device, and I’ve no plans now to change. Given our experience is so similar, you might want to look at the HH6 itself.

ac 16161
I have exactly the same problem with a similar set up. House is all wired Ethernet, but I have a BT HH6 for wireless duties in one part of the house, and an Apple AirPort Extreme for wireless duties beyond the reach of the HH6.

Using iPhone or iPad and the NAIM app to control my NAIM devices , it can often (but not always) take 10-15 minutes for the NAIM app to discover any of my NAIM devices if I move from the HH6 area of the house to the Airport area of the house.

Annoying, but have given up trying to understand it or fix it. A simple workaround for me is to leave an old device such as an old iPod or iPhone in each area simply for control purposes.


Thank you folks. Finger is firmly pointed at the HH6 which I did suspect.

I like your workaround Paul. I’m sure there is something lying around the house which I can use in situ to act as a control.

Many thanks all for your ideas.

No, the HH6 is an advanced bit of kit that supports many protocols correctly, it is designed to support BT TV and other more advanced apps which need more advanced capability from a broadband router … and almost certainly it’s how you have you have setup your two access points… ie you have setup them up as two SSIDs as opposed to cooperating ESSIDs. I suspect it may be something like SSDP group snooping… and when switching APs you are needing to wait for the new AP to understand what group your Wifi hosts are belonging too… possibly not helped by the probably relatively poor performance of multicast over your powerline adapters bridges… you really should try and use Wifi or Ethernet.
So the answer could be use a single BTHH6 or use disable irs Wifi, and use proper cooperating WAPs set up as an ESSID… if you use Ethernet between the APs and a good switch, that will work perfectly… it’s ehat I use here… I use Ubiquiti access points and Ethernet. I also get the advantage of more efficient Wifi with IGMP snooping enabled and instant Naim app discovery. (Assisted by a group querier)

1 Like

I suspect Simon’s point about SSIDs is the crux of your problem. Is your second wireless access point provided by the powerline device itself, or do you have another WAP connected to it?

Thank you for continuing to think about this. I think you are onto something although I have to confess to not really understanding Simon’s post. :slight_smile: But some not completely conclusive testing indicates that disabling the Powerlines solves the issue.

An ethernet connection to the remote AP is out of the question for many reasons (including my marriage!). Wireless would require an intervening AP due to the distances and wall thicknesses involved.

I am also reluctant to change as the current set up works fine apart from this one issue and I do not in fact need the second access point for the app. Despite all the comments about Powerlines, they work well for me. They are only really used for streaming to the TV at HD quality and to provide wifi around the parts of the house that the HH6 does not reach and, for those purposes, they work well - reliable and no buffering/drop outs.

I still can’t get my head around why the app will always immediately find the rooms on the remote AP but, on the HH6, only finds the wirelessly connected Qb immediately and not the ethernet connected Core and Nova.

In case it is relevant, the second AP is actually an old HH3 which is connected by ethernet to the powerline at one end and the other powerline is connected by ethernet to the HH6.

Is it possible to set this up as a ESSID (whatever that is) and, if so, is it possible to put the procedure into language an idiot (i.e. even me) could understand?

I’ve never used BT network equipment, but someone who has will probably be able to help. I’m not sure if the HH3 can be reconfigured, but if not, a different WAP may help.

An ESSID is where two or more Wifi access points jointly provide a common WLAN by using the same subnet, Service Identifier and authentication. This Allows the WAPs and the client to pass across the access points whilst keeping many of the network paraders the same. These cooperating access points may use standardised and proprietary methods to talk to each other … so typically when doing this they will from the same manufacturer/product set.