Asset UPnP issue

I don’t often has issues with Asset and, if I do, it’s usually me being daft and the problem is easily solved. However now I have something which is probably more major :frowning:

Let me start by saying I have a new streamer which comes with it’s own app :frowning:

Anyway the problem is I select my album as usual on the new app BUT the streamer queues the tracks in alphabetical rather than track order. Very annoying and I admit it took me a while to spot what was going on :frowning:

So I complained to the streamer manufacturer and they said the issue is Asset is sending the list of tracks to the streamer in this alphabetical order not track order and it was known issue. Well the same album sent to my NDX gets queued correctly in track order so, if this IS Asset, then it looks like the NDX was resorting the tracks before adding to the queue but the new streamer doesn’t.

I can ‘fix’ the issue by changing the text for the track titles so they have the track number appended on the front so, for example,

Dreadlock Holiday
01 Dreadlock Holiday

It’s a bit of a botch and, with 20K tracks to do, a fair amount of work (though mp3tag can easily do the change) and not something I’m keen on doing.

Alternatively use Minimserver which works fine but, good grief, I’m finding Minim a lot more work than Asset :frowning:

Please advise… what’s the concerted thoughts on this issue?

I suggest you say what the streamer and app are, in case someone else has one. I’ve used Linn Kazoo and Asset works fine. Asset only sends what the app tells it to send, so is does sound like an app issue.

If you don’t get an answer here, try the dbpoweramp forum and you should get a quick answer.

1 Like

It’s non-NAIM - sorry :frowning:

Bartok using their Mosaic app.

Hmm. I’d ask on the dbpoweramp forum in that case. It would be a shame to have to edit each track. While it may be easy, having the number in the title looks messy. Maybe there is an Asset setting. Whatever, they will be able to tell you.

Yes… I asked there but the answer was pretty much it’s the other guys fault, ask them :frowning:

That’s not very good. If Asset works with Naim, Linn and others, then the ‘fault’ surely lies with the Mosaic system.

If the albums have track numbers correctly tagged in the metadata, best if in 1/1, 1/2 convention, but 1.2.3. works as well. If you have that - as I do & I suspect everybody - and Asset works perfectly for everybody, then it has to be the new streamer & I suspect its app. Have you tried another ‘generic’ app such as you find on www? If that gives tracks in correct number, it has the be the streamer and/or its app

All of my albums have numbered tracks, regardless of whether they are CD rips, or downloads from various sources. So if yours are missing the numbers, that seems a bit odd to me. Note that the numbers are visible if you browse the files via a computer, but not if you view the metadata, as you would be in the Naim app etc.

I mean the tracknumber tag has, for example, ‘1’. The title tag is ‘Dreadlock Holiday’. So the track number IS there in the tag.

I have 2 hi/res files that show the track numbers in the song tiles when playing. No idea why.

Well MM4 and mp3tag say the tracknumber tags are correct so, I must assume, they’re okay.

So you are adding these numbers manually, and then they are visible as part of the metadata in the app? If so, that shouldn’t be necessary if the actual track file names are numbered.

So, for example, I have the following…

All the media programmes I have access to show the tag is correct. The problem is I can’t get a true answer from anyone at Asset whether it’s true or not? I mean are the tracks sent in alphabetical order to the streamer or not? If not then I can go back to the streamer people and say this isn’t the problem. The other option is to traffic trap all of the requests to Asset Does Asset have a log that would tell me this?

That looks correct to me - file name with number, metadata tag with no number. So I would think that the Naim app is working as intended, and the other one isn’t. Perhaps it has a setting tucked away somewhere that puts lists in alphabetical order?

I’m probably being a bit simplistic here, but to my mind, if Asset sent the tracks in alphabetical order, everybody would see them in alphabetical order. Albums are arranged in number order so it cannot make sense for alphabetical order to be sent. If you strip out the titles the tracks will still play, in number order. I wonder what would happen in your case? You could make a copy, strip the titles, leave the track numbers and see what Mosaic does. Maybe nothing.

The guy responding on the ‘other brands’ forum has a job title that gives the impression he knows what he’s talking about.

In the Mosaic user guide it says it does UPnP with Minim but doesn’t mention Asset.

Correct but they say Minim simply because they only want to go through the hassle of knowing one particular server package. It’s not to say it won’t work with other packages. In fact I had a pre-purchase conversation and they pretty much said as such.

I think first stage is enable the Asset debug log and see if that tells me anything. Assuming it shows the track URLs going across in track order (NOT alphabetical) then I can go back to dcs with the evidence. If it does indeed show the track listing being sent alphabetically then it’s a case of stick with Minim or redo all the titles of my tracks.

Heck that sounds like a recipe to confuse the app :wink: