Asset UPnP R7.4 released

FYI - Asset have released R7.4 for all product types - QNAP, Synology (DSM6 & 7), OSX, Linux & Windows.

It includes a significant number of updates & fixes all listed in the last (7.4) two posts in this thread …


First time upgrading Asset on a Synology NAS, but can’t find the proper instructions :sweat:

  1. Should I be downloading the latest version from the product webpage?

  2. Assume I need to do a manual install from the Synology package center page. Are the prior settings and configurations preserved?

I always do a backup of the config directory… just in case.
Then shut it down.
Then install over the top.
Reboot PC.

Download the Synology (.spk) package from Asset, be sure you download the correct DSM6 or DSM7 specific to whatever DSM package you have.

Yes it’s a manual install on your NAS & all your previous settings are preserved.

However I always keep a plain text copy of my preference settings as a matter of course.

1 Like

Thanks! :+1:t3:


Updated from R7.0 to R7.4 on my Windows test server about a week ago. No problems.
Saw the release info on this thread so thanks @Mike-B
Maybe better to delete the old one first.
It fixes an https playlist bug I reported to Asset (http worked but not https) so thrilled about that.

Hi Paul, no need to delete the old revision, in fact it’s best not to as that looses any personalised Browse options you have, .

Does one have to re-register the licence key or does it just update with the new package?

No need to do anything except install the new R7.4
It updates over the existing licence key.

1 Like

:+1:t3: thanks

Since I upgraded to this release, all my multi-disc album rips are showing up as separate albums despite having the Multi Disc Album option set to Combine multi-disc albums as one

Is anybody else seeing this behaviour? For example looking at David Gilmour these two used to show as a single album with all tracks in the play queue.

Any solutions I’d love to hear them!

I suggest asking the Asset (dBpoweramp) forum

I’m Asset & have my multi disc albums set to show as separate disc, but resetting to show as one works correctly…

I’ve updated to 7.4 and my multi disc albums are still showing as one.

On a QNAP NAS? Would you mind posting a screenshot of your settings so I can compare?

After updating went into AssetUPnP Configuration.
Mine states “Functionality: Premium registered”.
So seems to recognise a registered version.

yep, QNAP

Thanks for that. Alas I’ve made my settings the same as yours and multi disc albums are still not grouped together. I’ve also asked the question on the Asset forum but if no answers are forthcoming I’ll uninstall and re-install to see if that helps.

Just tried the uninstall, re-install and the problem persists

I’ve gone back to Asset 7.3 and multi-disc albums are once again showing as a single icon when browsing. Maybe I’ll just stick with that.