BubbleUpnp on QNAP. help With setup

I have installed Bubble on my QNAP to have aplay around with it to see what it can do.
I have set it up but notice the following is greyed out Screenshot_2021-05-06 BubbleUPnP Server
How do I get this to “ungreyed out” so that i can play with it to see what it does?
Thank you.

Simple answer is run it in a container as the QNAP ffmpeg is broken

I had this issue and Bubble sent me the following commands to run from the prompt:

cd $(/sbin/getcfg BubbleUPnPServer Install_Path -d “” -f /etc/config/qpkg.conf)
mkdir custom_ffmpeg
cd custom_ffmpeg
rm ffmpeg ffprobe wget https://johnvansickle.com/ffmpeg/releases/ffmpeg-release-amd64-static.tar.xz
tar xvf ffmpeg-release-amd64-static.tar.xz
cp ffmpeg-4.3.2-amd64-static/{ffmpeg,ffprobe} .
rm -rf ffmpeg-release-amd64-static*

worked fine on my qnap. I restarted and works.

Hi @elverdiblanco
Screenshot 2021-05-07 at 11-27-57 BubbleUPnP Server
This would appear to show that ffmpeg is working for audio, without being in a container.
Thank you for your information and the images to make it simple to follow.

Hi @solwisesteve
Thank you for your reply.
Unfortunately I am not familiar with computer programming and do not know what commands are or what the “prompt” is or where to find it and how to use it.

Is it working for you now? I’m sure I had that and the transcoding options were still greyed out. Using a container sorted it out and those options all now show green

Hi @elverdiblanco
Audio and Image are coloured green and say “yes” and Video is coloured yellow and says “no”

Sure, I can see that but are the transcoding options still greyed out or are they working?

Hi @elverdiblanco

I have had a go at creating a locker and have this

It says it is running but now I cannot find Bubble amongst the apps to go into the settings of Bubble to set it up and see the transcoding options?
Thank you.

Sorry you need to use PuTTY to login to the raw console. If that’s beyond your knowledge then it’s difficult over messaging to advise, however

First of all you really need a ‘proper’ PC to do this. Goto putty.org on 'tinternet and download putty.

Run the putty.exe programme after downloaded.


Where it says Host Name enter the IP address of your NAS. Click on Open. Note the image below shows MY address for MY NAS. Yours will be different…


On the login screen enter admin for the user and then the password you made for your qnap.

You should then see…


Enter Q to get to the console…


Now you can copy and paste the commands I mentioned before.

Then restart qnap.

for putty…

Sorry the pic is too small for me to make anything out but if you have installed Container Station and the docker image inside it as in the instructions in the other thread you won’t see bubble in the main list of apps. Instead just use your browser to look at the setup on your NAS at port 58050 so just put the name or IP of your NAS in the address below


If you have everything set up properly you should see a screen like this

Hi @solwisesteve
Thanks for this I managed to follow this on my PC. The only thing I was unsure about is this "Then restart qnap.

for putty…"
Do I just restart my QNAP NAS or do I have to do something with PUTTY.
I pasted your command lines into PUTTY and was unsure then what to do next.
Thank you.

If you’ve executed all those commands in a putty window just close putty and restart the NAS.
However, if the bubble in the container is working properly you may end up with port conflicts so disable the bubble in the container before you restart

The container is the easier route and it just works. Messing with the ffmpeg may work initially but many report it usually gets messed up after firmware updates requiring you do it again. The most I’ve had to do with the container is just restart it.

To be fair, I was going to go that route BUT not enough RAM on the QNAP. Easy to solve you think, so I purchased some more RAM and then found that the QNAP is walled in behind a tall cupboard and no way to get it out! I can reach the unit but it won’t slide out underneath nor to the side :frowning: So it’s staying there until the dresser comes out for the promised redecoration of the living room. Meanwhile I’m avoiding any f/w updates just in case though, tbh, I could easily rerun the ffmpeg installation if it got overwritten :wink:

HI @elverdiblanco
Thanks for your help but it does not seem to want to work for me. I will leave as is.
Thank you once again for your time.

Hi @solwisesteve
Thank you for your time and help.
This does not work for me though.
I have an Intelx86 and I see the command is for a amd64

Now that’s strange… my QNAP is also Intel but I never spotted that the commands/files said amd64… I just copied and pasted and it worked so never thought any more of it!

However there is an intel set of files on the johnvansickle web site


So you could change the commands to reflect the intel files. The latest version is 4.4.

However, maybe it’s getting too convoluted.


The container way is by far the easiest as long as you have sufficient memory in your NAS. The instructions for installing it in a container posted by CrystalGypsy in the thread I referenced earlier are comprehensive and fairly simple to follow. If it isn’t working for you there’s probably an easy solution if we can see exactly what you’ve done

1 Like

Ok, but looking at my container it’s not a significant drain on resources. It’s run without a hiccup so far.