Can't access Tidal via Focal & Naim App

I reinstalled the Focal Naim app on my iPad a few days ago. I now cannot login to Tidal via Focal Naim. I can, however, login to the separate Tidal app, so I know my login and password are correct. Also the option to logout of the Tidal app in Focal Naim (Settings, Input Settings, Tidal, Logout) has disappeared. Any suggestions please?

Same issue here. Not sure if the password log in process is the same for the Tidal app and the Focal Naim app but whenever I attempt to use Tidal via the Focal Naim app I get an error message saying I cannot log in. I have checked my subscription and it is up to date. I have also restarting both my Internet and my Naim system (using a 272) but no progress. Any help appreciated

The logout option is still present on the latest android version of the app. Doesn’t really help if you can’t see it on the iPad version :-). You could try turning it off as in input on the app and then re-enabling it as an input. I’m making a guess that turning if off will wipe the settings and then present you with the login options when you re-enable it…

Thank you. I tried that yesterday without any joy, even completely closing the app after removing Tidal as an input, and then starting again.

What streamer are you using and what firmware version is it on?

If you are using a legacy green screen streamer and a firmware version that isn’t 4.8, then that is almost certainly your problem.

1 Like

Same issue. I can directly log into the Tidal app but not via the Focal Naim app with exactely the same username/pwd.

Same question, what Naim streamer are you using and which firmware version is it running?

To David Hendon, Many thanks, now sorted. Firmware was v 4.7. Only took about two hours on the phone to my company IT support, and dismantling my Man Cave so that I could connect my laptop directly to the streamer. Thanks for your suggestion.

1 Like

Ndx5 xs and 4.4
I’ve tried to upgrade my streamer to 4.8 but after 2 hours trying to install a usb driver i gave up…
But 4.8 is not new and i could connect a few days ago. How would it be a solution?

Tidal authentication was changed over a year ago and the firmware update dealt with that. I’m more surprised that people have been able to connect for so long without having updated to that firmware version :slight_smile:

1 Like

4.8 specifically includes patches for a Tidal login issue that was expected to happen sooner or later, depending when Tidal flicked the switch. In practice there have been quite a few people reporting sudden problems with Tidal this week. And if you read recent posts you will see that installing 4.8 did fix it for some people.

4.4 is way out of date and you definitely should do this update. Why are you having trouble installing the USB driver? Maybe we can help with that.


I posted this elsewhere, but think that it bears repeating. I had the Same problem with my ND5SX. After frustrating restarts, I read the manual (only do this when all else fails) and updated from 4.6 to 4.8. Now happily listening to Tidal again.

To save anyone else the pain, follow the instructions here:

Help Centre

How to install Firmware 4.8 on a Naim streaming product?

Naim is preparing to launch key firmware updates for its legacy streaming products. These essential updates will ensure the products can continue to stream TIDAL, which has implemented a new login authorisation process that affects older generati…

Always nice when instructions are clear and they work!


As a postscript I will add that make sure you install the correct USB drivers on your laptop or PC as that will definitely cause issues.

Yes that is good advice. The relevant drivers aren’t new or anything like that. They turn the USB port into a virtual serial port, which is what the Naim streamers need for updating.

There are a few other things that often cause issues if people don’t follow the instructions to the letter. One is that you mustn’t run the updater program until the streamer is connected and switched on. If you have the updater program running and then make the connection to the streamer, you may find that you cannot get the virtual driver to actually run and so the updater program won’t find the streamer that you are trying to update. A second is that you must have your laptop connected to the streamer through two means throughout, ie the USB lead and Ethernet or WiFi. This is because part of the update is delivered over the USB lead and part is delivered over the network. A third is that if you just cannot get the updater to see the streamer, try a different USB lead. Some of the leads that found their way to peoples’ homes were intended just for USB charging and didn’t have the data connections made (of three leads I found at home here, only one worked for me).

And finally the PC finishes stuff before the streamer does, so just be patient and don’t disconnect anything until the streamer has obviously finished.

And in the old days we just put an LP on a turntable without all this aggro. Many thanks everyone for your help.

1 Like

Thank you all for good advice, I was able to fix my SuperUniti by upgrading to 4.8. luckily I found a matching USB A to mini-USB B cable. Upgrading with Mac is pretty straight forward plugin the cable start the Naim UpgradeApp click yes yes next next, watch for several reboots of the Naim device and several separate firmware images getting installed. The App clearly indicates when finished!

You need to download and install drivers from Silicon Labs. It worked for me.

Problem I have is the screen on my nd5 xs packed in about 2 years ago which hasn’t bothered me in the slightest, which unfortunately means I can’t check to see what firmware I’m currently running.

Let’s hope Spotify Hi Res launches sooner than
later so I can cancel my Tidal subscription

1 Like

you can check current firmware via App.

nope I did not need to download any drivers!
“For macOS 11 Big Sur or later, you do not need to install the serial driver if your product has a mini USB port. You can select the ‘usbserial-001’ device in Streamer Updater to do the update.”