Chromecast issue

Hi Naim Community.

I recently purchased a Mu So Gen 2.

Updated firmware.

Have great network on a Netgear Night Hawk R8000.
Have lots of smart home devices, cameras and other google home products. So I know it’s not my network.
I can also manually go into the MuSo web interface by typing in the IP address of the device in a browser.

Tried 5GHz network & 2.4GHz network, MuSo is not discoverable when I try to add a new device in Google home.

Airplay and Spotify can see the MuSo and seems to work fine.

HDMI ARC is set up with my Samsung Q95T One Connect Box.

I want to add the device to my Google home for easy casting.

Am I missing something? I’ve tried power cycling on MuSo and router already.

No other posts about MuSo Chromecast built in not being discoverable.

Regards,
NINJER.

Apart from Google Home, do you see the Chromecast device from any apps that support casting?

I don’t have a Mu-So Gen 2, but with my Uniti, you need to agree to the Google/Chromecast terms and conditions during initial setup. And I don’t think there’s a way to change that afterwards. If the same, is it possible you didn’t agree initially? If so I think your only option is to do a factory reset.

Spotify can cast to it, since it has Spotify in built, but Poweramp, YouTube music, any google casting enabled app can’t see it.

I have tried 3 times, once on my iPad, once on my note 9 and once on a Google pixel, none of them ask for me to agree to google. All it does is ask you to open the Google home app and add the device.

It is possible there is an issue with the google token. If you have exhausted all avenues, you will need to contact naim support.
Try completely resetting the mu-so if you haven’t already.

1 Like

Agreed a full factory reset should be your first move.

After that, ensure you agree to the Google Ts and Cs when you start set-up again.

Then follow the Add device route as you’ve been trying so far.

Good luck, and let us know how you get on!

I have tried 3 times, on different devices too, including an iPad, the app even after reinstalling never asks me to agree to terms and conditions, during the setup process when it goes to casting tab, it only says before being able to use casting you need to configure the device in Google home, and there’s a link to Google home at the bottom.

Have you stuck a pin in the mu-so reset hole and then set it up again in the naim app?

Yes, as above, I have factory reset 3 times. And used different devices for set up as well.

Silly question, but are you sure it’s a Gen 2? The Gen 1 didn’t have Chromecast.

You’ll need to contact Naim support ref the google token not working.

I know it’s a gen 2, the box says so, and also during set up it tells me to go into Google home app to add the device. I also have a photo of the bottom which says it’s gen 2

1 Like

I set up my Mu-So QB2 yesterday. I don’t recall any Google-specific terms and conditions (although I might have agreed to them blindly).

Google Home found my Mu-So without any problem (with a Netgear Orbi router). But I have had failed additions in the past, Usually, if I’m patient, Google will find it on a second try.

1 Like

After speaking to Naim Support, they say it most likely is a Google token issue, which can not be user fixed.

I would have to take it to a authorized naim repair partner. Quiet dissapointed if I had to repair it instead of replacement, I literally have had it less than 2 weeks.

However luckily in Melbourne Australia there isn’t one.
So they have asked me to get a replacement from where I purchased it.

This is the only post about this issue if you try to google, and only 1 other mention about a google token.

How lucky am I to get a Mu So with a problem this rare…

I must say I thought that they, Naim support, could contact Google and get the token issue fixed remotely @Stevesky?

Best

David