dBpoweramp garbling first track of rip

Long story …

about 4 weeks ago my 10 years old iMac and my iPad Air both ‘died’. Rather than get them repaired I opted to get a Mac-Mini (16GB, 2TB SSD) + screen, and a new iPad Pro. I did debate going back to a Windows PC, but couldn’t face the thought of changing various bits of software. The dimmer switch in my study failed in the same time period. It must have been one of those weeks, because several other things needed repairing about the same time!

Anyway … all has gone relatively smoothly, and I did most of the reinstall using my Time Machine backup. I’m still using my old Apple Superdrive. Had to update dBPoweramp and a few other bits of software, but c’est la vie.

Since then I have ripped about 6 CDs. The remarks here refer to first CD rip failure. dBpoweramp settings secure/FLAC. Each time I cancelled the rips because it was saying 15000 things needed rewriting (or something to that effect). Plugged in my old external LG DVD drive. Same result. Tried ripping to WAV - same result. Tried Burst mode rip. Tried the Defective by Design setting Same result.

What next? Well, I did the rip (to FLAC/Secure) but unticked the first track. Rips all went perfectly! Converted them to FLAC with dBpoweramp

Ripped the first track to WAV using Apple Music App. Dragged to file to VLC, OK. Made a copy, and edited the metadata using dBpoweramp. In one case the metadata edited file became audibly glitchy. Deleted the glitchy file, made another copy and edited the metadata using Music Tag Editor. Played OK using VLC. Tried dBpoweramp again to convert it to FLAC - file again glitchy.

(sigh) Got fed up with the nonsense, did another rip of track 1 using Apple Music, but this time to Apple lossless, and that’s the version now sitting on my NAS.

The rest of the CDs went pretty much the same way, but for these I ripped track 1 to WAV, changed metadata using Music Tag Editor, and converted to FLAC using dBpoweramp successfully! (hooray!)

All the CDs play OK (using my Oppo 103 as I don’t feel like unboxing my Naim NDS at the moment), so they are ‘pukka’. Hence cannot be a batch of faulty CDs. Used 2 DVD drives, so unlikely to be that. Why do I have 2 drives? Well, my old external drive let’s me rip some discs that the Apple Drive fails with. Disc surfaces visually perfect.

Is this a known problem? I’m seriously debating just using Apple Music for my rips and then Music Tag Editor for metadata alterations with dBpoweramp as file converter.

I’ve been ripping CDs with dbpoweramp without problems. I wonder if it’s because your drive needs calibrating to work with dbpoweramp on a new computer.

You may well be right. I did consider that when the problem first reared its head. I had already upgraded to the latest version of dBpoweramp because my older one wasn’t working on the new Mac.

I looked through the secure setup advanced settings to see if I can force a manual calibration, but all it says about the offset is that Accurate rip detects my drive and will pick the appropriate manufacturer settings. Alas, the Mac version of dBpoweramp doesn’t support Accurate Rip, although it still reports if a ripped disc is in Accurate Rip!

Can’t see any obvious way of doing it manually, although apparently Accustream is necessary. I don’t know if that is available for the Mac. Perhaps Mr.Spoon will know?

addendum : Just had a thought. Perhaps if I turn off Accurate Rip and just accept Burst mode, then it will work. Testing that will have until the next time I buy a new disc to rip. I’ve got “Deep Purple Made In Japan” in my basket on Amazon, but wasn’t planning to complete that purchase until I have something else that I want. Don’t want to have the delivery bloke coming with just one small item!

Maybe it’s time to embrace downloads.

Something doesn’t seem right, I’ve never had any issues using the default settings of dbpoweramp (w/accurate rip) ripping to the hard drive on my MBP. HH has a point, I do enjoy the quality of Qobuz rips, so much easier and the work is already done.

I suggest posting the problem on the dBpoweramp forum. I expect Spoon will have the answer

I’ve ripped over 1000 CDs using dBPA on my iMac with a SuperDrive. Using the default settings for dBPA, the great majority have ripped without issue. Where I have had problems it’s always been with the first track. Sometimes a thorough clean of the CD, particularly the inner part of the disc where the first track is located, has cured the problem but very occasionally I’ve resorted to your solution.

BTW I think different Apple SuperDrives have internals from different manufacturers so settings such as offset may vary from one to another.

I second @Mike-B’s suggestion of posting on the Asset forum. I’ve always found Spoon very helpful.


When we bought an iMac we needed a CD drive. I did a bit of research and the Nolyth was well regarded. It rips happily and seems pretty solid.

I’ll ask on the dBpoweramp Forum. I had no such problems when I first migrated from Windows to Mac, and both my drives functioned fully. The only thing that was different is that the results of secure rips on CDs not in the Accurate Rip database could not be uploaded to the Accurate Rip Server.

The drives I am using are the same ones that I was using for dBpoweramp ripper on my iMac and I don’t recall having to set them up. IIRC my Apple drive appeared on the CD ripper not as Apple drive, but with exactly the same data as my LG external DVD writer drive. So why are they not working correctly with dbPoweramp on the Mac-Mini?

Could have sworn it used to support it - no longer does?

I think dBPA on Mac can compare a local rip with what it finds on the the Accurate Rip database, but cannot submit a local rip to the database. At least that is my understanding.


It still reports if a disc is in Accurate Rip, but the Mac version does not upload Rip data to it. The Windows version, IIRC, does.

1 Like

Mr. Spoon has responded, requesting a logfile. While generating one for him using an already recently ripped CD I discovered that if I set the secure rip to abort early (secure settings tab), then it rips track 1 and then rerips it and produces a playable version. If I don’t set a time to abort, then who knows how long it would take - Strange Fruit (Billie Holiday) wanted to re-rip almost 14000 frames!

If I untick track 1 and leave CD Secure Rip to its factory settings, then the other tracks rip with no problem.

I looked in the Accurate CD drive database just now, and my LG DVD writer is there, but not the Apple Superdrive.

1 Like

But dBPA on Mac does compare the local rip with the Accurate Rip database, which is what matters IMO, at least provided there are enough Windows uploads to the database.


1 Like

Interesting. I looked for the Superdrive as well but couldn’t find it. Presumably it’s a non-Apple CD/DVD player in there but couldn’t figure out what it was - maybe a specific search on the model number might turn up the info? (thh Axxxx number). Teac springs to mind for some reason but that may have been drives in an older Mac I have and I suspect teh actual drive might have changed over the years depending on parts availability.

Apple have used various different third party drives in their Superdrive enclosures despite the fact that they all look the same on the outside. None of them work with Accurate Rip because Apple don’t support it. I presume they see it as irrelevant as is outside of iTunes/Apple Music.

I don’t think Accurate Rip needs Apple to specifically support it on the drive, more that the drive needs certain specifications to allow Accurate Rip to work.

Possible I suppose that macOS is no longer allowing access to some of the low level features required but that would seem odd if other drives work.

Just to clarify - are you saying that it’s not comparing with the database to confirm a bit perfect rip or that it’s not updating the database from your rip to support a wider user group which would be more useful for discs with no or few recorded rips?

Just wondering, if you bring up AboutThis Mac from the Apple icon top left and generate a system report, does it show any info regarding the drive type in the Superdrive in the USB section?

It’s Mac OS that doesn’t support Accurate Rip. I suppose it’s possible that a Superdrive might handle it if used with a PC.