Difficulty updating to 4.7

Hi folks I have done lots of updates to various naim streamers and never had a problem. My difficulty now is that I have a new windows laptop, with windows 10 and I’m fairly sure I have installed the drivers correctly from Silicon Labs but I can’t fiind any way of checking them in device manager and see which com port is being used. I don’t get the option to see Ports and I’ve tried showing hidden icons but still nothing.
Is it ok to go ahead anyway or is there a way to check that the drivers are correctly installed?
Thanks in advance for any help.

Same problem, only on Mac, MacBook Pro 2018, Silicon Labs uart driver shows as installed but no serial port available from within Naim updater…

And a COMPLETELY out of date pdf guide, so no clue as to next steps.

Not the first time, eh boys?


If you follow the install process written in the instructions, you will come to a screen with this picture
It does not show COM6 or any COM, its a touch drop down, touch the arrow pointer & it will show just one COM number, probably COM3

Is that what you get ?? if yes keep going to complete the install.

Success on the the third attempt - and the trick is, at least if you are running MacOS 10.14.3, is to click the SiLabs download link in the out of date PDF guide included in the 4.7 update package [
http://www.silabs.com/Support%20Documents/Software/Mac_OSX_VCP_Driver.zip] (irony noted) - this downloads the latest SiLabs driver for Mac [CP210x Macintosh OSX VCP Driver 5.0.8 - February 12, 2019] which, somewhat bizarrely, does not appear to be what you get if you use the download link on the SiLabs site…

You may also have to play with the SiLabs provided uninstaller.sh shell script if you have installed earlier versions, depending upon your installed version of MacOS.

And lastly, of course, Auntie Apple prevents the newly installed device driver from loading, so you’ll need to allow it from within System Prefs Privacy page - this is covered in the PDF file.

If you successfully complete the above, you will be able to select the SLAB_USBtoUART interface from the updater drop down menu - assume COM6 above refers to Windows OS - and proceed to update your system.

Hope this helps.


I think that if you connect the USB cable to your Naim device & power it up, the com port should pop up in the device manager.
An exclamation mark next to it would indicate a driver problem.


Ok, 272 updated to 4.7 all completed smoothly via my new windows laptop. The difficulty arose because the naim instructions assume you can check the com port through device manager as Neil advised above but you can’t. You have to start the updater and hope that com 3 appears.
Somebody clever than me will have to explain why Ports is no longer listed in device manager, or is it just me?
I think the naim installation instructions could have been more comprehensively updated, including the out of date screenshots.
Thanks anyway.

My com port showed up in device manager when I installed the driver, first time I have done this on my NDS as my previous NDX had an old fashioned serial port. You just need to download the drivers and install them and it should appear.

The port will be different depending on your PC, mine was on port 4, Mikes was on 6 and others have reported port 3.

Your COM ports are listed in Windows-10 Device Manager, you need to activate the Show Hidden Devices

I did that and it still doesn’t show them. Lots of queries about this on windows websites.

Having looked at what 4.7 offers, I can see absolutely no reason to put myself, or my dealer, through this pain!

Another glass half empty

It’s really easy and my obsessive nature likes to have the most up to date firmware. It sounds really good, seems to work smoothly. Don’t forget to do a factory reset after it’s finished updating.

I haven’t done that for quite a while John, & I’ve installed dozens of beta’s over the years. The only time it was actually a real requirement was when the BBC HLS service was implemented. I did run a reset once just because it sez to do in the instructions, but it makes no difference.

Interesting. I’ve ended up doing it most times cos it says so. On this one after the update everything was fine except Tidal which wouldn’t play at all. After the factory reset everything is perfect.
Have been listening to Tidal all afternoon without a hitch. I rarely had dropouts before the update.

Yes agree, interesting. I’ll give it a try to see if anything else comes up, I don’t see a Tidal issue as I don’t use it.

Not a bit of it. The last upgrade gave my dealer a 2 hour headache, was an absolute b**ch, but at least contributed an uplift to the SQ of my 272. I can see nothing applicable to my use in 4.7
that will contribute anything of value to my listening experience. If the subsequent version does, and requires 4.7 to install, then will be the time. Makes perfect sense to me.
On the old platform these updates are not easy or straightforward - the sooner we get a 272 running the new platform (372 or whatever) the better. Improved performance and SQ, together with pain free, over the network software upgrades - just the ticket!

1 Like

Sorry you & your dealer had a bad experience, goodness knows what went wrong. I’ve updated dozens of times with all sorts of beta variations, it takes 10’ish minutes.

not sure whether this is the right place to ask else I will start a new thread:

but can I please hear from folks who had SQ problems with NDS4.6 but who have upgraded happily to 4.7. I am opted to stay with 4.4 after a few stressful ups and downs with 4.6

many thanks

I’m happy with 4.6, but I’m seeing people saying that 4.7 sounds the same as 4.6, so unless one of the issues mentioned as fixed in the release notes for 4.7 bothers you, I would stick with 4.4 if I were you.


1 Like

I updated my Superuniti at the weekend and happened to notice this message

Is this normal?
I should add I have just received the Superuniti back from Salisbury after they changed the digital board to fix the optical input housings. So don’t think there is anything wrong with the unit and it sounds great. I should add the screen is correct on all day to day usage.