Disk won’t rip

Just tried to rip Boris Giltburg’s Rachmaninov Etudes-tableaux on the Unitiserve and, three times, the disk has gone in and not ripped.

I’ve ejected it using the paperclip method, rebooted the US and still no luck. It’s as if the disk is not in there.

Anyone had similar issues? Any suggested fixes or could it be the CD itself?

Many thanks

1 Like

I use an HDX for ripping, and on the very rare occasion that a disc won’t rip, I’ve found that a quick and easy fix is to use Titanium Toast to rip/copy it to CD-rom on my Mac, and then rip that with the HDX.

I’ve no knowledge of the US, but first thing I’d do is stick another CD in you’ve ripped before and see if it works - if not possibly the US is u/s.

Otherwise it could be the CD. Either damage, or some apparently have copy protection (which might affect sound quality). Try ripping in a computer - some ripping software will rip things with copy protection, I use dBPoweramp for ripping: no idea whether or not it will rip protected disks, but it has more intensive ripping options to try to rip disks that fir some reason are difficult.

What firmware does the Unitiserve have? If it’s still on 1.7b and you have been doing a lot of ripping, the queue of tasks for the defunct AMG metadata service may be so long that the CD never gets past the lookup stage. As has been said by others, checking ripping of a known good CD is a very good idea.

The new Unitiserve firmware 1.7c should fix this but you have to get the update CD from Naim or get your dealer to do the update. It’s not downloadable from Naim’s website.


Thanks all. I’ll try ripping a CD that I’ve ripped before.

David - I’m on 1.7b so perhaps I should contact Naim to get the update CD.



A previously ripped CD ripped fine. I tried the Giltburg CD (Naxos) straight after and still nothing so I guess I’ll try the 1.7c update to see if that fixes it.

If its a queue problem as @davidhendon suggested I would expect it to gave still struggled, so to me that more suggests the disk.

I agree with @Innocent_Bystander. It sounds like the disc to me.

Ok - so it’s possible for some discs to be un-rippable on the US?

Does it play ok on different CD players? Is it new?


Brand new. Naxos. It plays on a CD player.

I wouldn’t spend too much time trying to work out the ins and outs of why your disc won’t rip, as the easy way round the problem, suggested above, has worked every time for me.

It probably is copy protected. So copying it in a PC to a blank CD and ripping that in the Unitiserve or alternatively ripping it on a PC and pasting the files into the downloads folder of your Unitiserve probably is your best course of action.


Hi Dave,

There are many factors involved in the mastering of CDs, many of which fall outside of the “red book” standard. I’m sure that you’ll agree that it is impossible for any manufacturer to ensure that their equipment will be compatible with every available disc.
If it’s only this one disc causing you problems, I’d agree with the suggestions of running a copy off & try ripping that.


On the rare occasions where my US has been unable to rip a disc, I’ve done it on a computer instead, and then transferred it to the Downloads folder. This has worked every time, so I suspect the US is more fussy than most.

I had this on a Blue Nile cd a while back. A search online revealed the first batch of cd,s had copyright protection. Music magpie gave me my money back.

Thanks all. Unfortunately neither my laptop nor my IMac has a CD drive so, unless I buy one for this CD, I’ll probably have to return the disc.

Thanks, that’s really reassuring. I had the same problem - again, the Blue Nile CD. Wouldn’t even read on the Naim. Used my MacBook to rip it and all worked fine. I’m finding the US is pretty fussy when it comes to CDs. 90% of the time I have ripping errors, I can rip the CD on the Mac without issues.

It may be that your US really needs a new CD drive. I had only one disc ever that wouldn’t rip without errors on my Unitiserve and that CD also ripped with errors on my Core when I got that. I must say the errors are not audible in the copy in the Core, to me anyway.

Anyway ripping or copying on a PC or MAC is definitely the way to go.


Thanks. I’m only near the start of my journey and have ripped c 400 CDs so far. Number of CDs with ripping errors was originally 11. Two or three of those had really obvious scratches but the others, less so. Using the MacBook to rip got the error disks down to three. Normally, I’m seeing the errors on the final track on a disk which feels a bit strange. I’ll keep an eye on error rates and maybe speak with Naim. The Star is only a week old after all…