Finding IP address

Hi Guys,
New to the community.

I am trying to hookup an ND5 XS. When I try to download the app it asks me for an IP address to continue. I can’t find it anywhere. I even downloaded the “net analyzer” and “Fing” apps but still no luck finding the address.

Any help would truly be appreciated (also I’m not very techie, so the simpler the better).


Do you have access to the control panel of your router? (Often the router is but might not be). What’s the make/model of your router? The control panel will list the attached devices and the assigned ip addresses.
Then you’ll see something like this.
Obviously you’ll need to have the streamer wired to see this.

You really shouldn’t need to have an IP address. You can download the app from the Apple App Store or Google Play Store and then when you start it up, as long as your ND5XS is connected either by WiFi or Ethernet, you will just find it in the Rooms screen.

You don’t set up the ND5 XS in the app incidentally. The ND5 XS2 is different in that respect.



If you are on IOS try this

Free app and works a treat.

1 Like

Yes but why? You don’t need an ip address to download the app.

Hi Guys,
Thanks for the replies.

In a nutshell, I plan to use the component for ONLY ONE purpose … streaming Tidal. So streaming is all I want to set it up for. I need the naim app to assist in using Tidal.

David … the app via Apple store that I accessed has just 3 options:

  • naim (for website info)
  • product setup
  • find rooms

When choosing product setup, you have choices among 5 current products and “enter IP address” if the product is not current. You can’t proceed unless it accepts the IP address imputed.

Choosing “finding rooms” results in a response “can’t find your device in rooms”

The above responses occur after my unit shows that it is connected to my home WIFI.

I know I can “set up” my component without the app, but I need the app for easier streaming control.

ray … I previously downloaded both ‘net analyzer’ and ‘Fing’. Unfortunately neither show my naim component (even though the unit says it is component to my WIFI)

On the 172, the IP address can be set/viewed from the tools menu using the remote control. Your device could be on a different subnet to your router.

The Naim app should find and Naim products automatically so the fact that it isn’t happening suggests something is not quite right. Did you buy the ND5 used? If so it’s possible that its previous owner fixed its IP address. You can change this in the settings so that it’s on DHCP, which allows your router to give it an address. Once you’ve got it working it’s worth noting that these legacy streamers work much better on a wired connection and you should do this if possible.

1 Like

The fact that “finding rooms” yields “can’t find your device in rooms" suggests that the ND5XS and the Naim app are on different networks or, more likely, that the Naim app misbehaves. Do you have wireless extenders in your network? Have you tried to restart the Naim app, the ND5XS or both? Have you tried to connect the ND5XS to your LAN with a wire?

Hi Naperaudio,
How is your streamer connected? I have recently had issues with app continuously losing my devices connected via a switch and wirelessly. I have resolved them by switching everything off and rebooting the router with only the Naim products connected directly to the router via Ethernet. The app finally behaved itself and I was then able to return to my normal network configuration.
I’m hoping the improvement in the app performance lasts but so far so good.

With ND5 XS you don’t need any of those options. The app will show it in the rooms screen without any configuration.

The fact that Netanalyzer and Fing can’t see your ND5 XS means that the Naim app won’t either. The WiFi on these old streamers is not good and as a couple of others have said, the best approach is to use ethernet cable rather than WiFi to connect the ND5 XS to the network. You will likely find that the app sees it straight away, although you may need to restart the app so it has a proper look, so to speak.



Building on David’s reply.

You don’t add the ND5 XS via the app. That menu option is for the later model, ND5 XS 2.

Your ND5 XS will show up automatically as a room. If the app doesn’t find a ‘room’, then either:

  • the ND5 XS is not connected to the network. Start with an Ethernet cable first if you can, otherwise connect to your WiFi using the remote, it’s pretty easy to do.
  • your mobile phone is connected to a different network from the ND5 XS
  • your router is inadequate. Do not underestimate this explanation!

I too recently bought the same model as you, and as David said the wifi capability is not strong and the connection (both wired and wifi) is heavily reliant on a high quality router.

I put down the cash for an Orbi router kit and it’s rock solid. Before this the Naim app sometimes didn’t find the ND5 XS at all, or TIDAL would drop out, it drove me potty. I tried to make it work with the very new but free router supplied by my ISP and was sceptical it could be the issue. I tried two others before finally caving and it immediately fixed the problem. A cheap router will not work reliably.

Edit: note, even with a high quality router like the Orbi, and trying a high gain wifi aerial in the back of the ND5 XS, the wifi signal to the ND5 XS was still not completely solid and would drop out during playback. Cabling it was the solution. So go for an Ethernet cable direct to the router. This was all at the recommendation of my local Naim agent who was brilliant and he was dead right. It fixed everything and has been solid since I set it up two months ago.

1 Like

Check your streamer is connected in your network. It sounds like it is not connected or in the same network as your wifi.
Your Naim app should find it, but only if it’s in the same network. Once your Naim app finds it… it is straightforward from there in the Add Room screen.

As others have said, there are free apps such as on Apple iPad / iPhone, Net Analyzer, which uses a simple discovery technique to see what is responding on your network… if you don’t see the streamer… then in it’s either

Not working / faulty (unlikely)
Eithernet cable not connected correctly.
Is on a different network than your wifi.
DHCP on your router is not working correctly.

As a hint, these days if you need to manually add ip addresses, the chances are something is broken or not set up correctly, it kind of is a legacy thing.

On Thursday I did a system scan using the Naim app while on phone to Naim support. They reported weak signals for my two wireless devices and couldn’t see the NDS at all, despite a wired connection via an EE switch. The problems seem to have been fixed, at least temporarily by rebooting with only the Naim products connected directly to the router and then reverting to my previous setup. Early days though.

Thanks again for all the advice guys … here’s my resolution.

I was trying to set up the naim in my basement (router is on the first level of our home). I use an eero mesh network to extend the WIFI signal through our home including basement. I thought this was sufficient as I had hooked down up a Bluesound Node2i in the basement through WIFI and it worked just fine. I was planning to replace the Bluesound with the “better” naim.

Well here’s the result … despite the NDS5 indicating it recognized my WIFI network it still was recognized in “rooms” to utilize the naim app. So, I took your advice and brought the NDS5 upstairs and connected it directly via Ethernet cable (I don’t have an Ethernet cable wired for my basement). VOILA … “rooms” now recognized my device.

So I guess, I’m going to pay a guy to run an Ethernet cable from my den to my stereo in the basement. The WIFI capabilities of NDS5 seem very limited.

You guys have been great … THANKS FOR ALL THE HELP!

1 Like


@naperaudio Instead of running a cable from your router to the basement, a mesh router can do it wirelessly.

The Orbi for example (which I have no reason to recommend other than it was recommended to me and has worked) comes with two devices: a router and a satellite which includes some Ethernet ports. The idea is you can place the satellite somewhere else on your property and it communicates wirelessly with the router via a fast secure back channel. It does not need to be cabled to the router.

In my case, I have installed the satellite near the HiFi and run an Ethernet lead to the ND5 XS. Bingo. The ND5 XS gets its cabled connection but I didn’t need to run a cable from the router. And I get a much better WiFi signal around the house to boot.

Cheers Ian
Edited to fix typos

Another thing you could try, if you don’t have Ethernet ports in your remote wifi access points.

Our local Naim dealer suggested changing these settings. Perhaps try these on your mesh router:

IGMP Snooping - disable this
2.4GHz signal - set to 20MHz only (channel bonding off)

I can’t speak to what impact these changes will have nor whether they are recommended, but worth trying to see if they make a difference.

Regards, Ian
Edit: more typos. Such fun using a phone to reply!

This is most likely the source of your issues. If the mesh network is not allowing discovery protocols to work properly then the Naim App won’t see the ND5.

But the fact will remain that most people find that connecting their old technology Naim streamers, like the ND5 XS, using WiFi is highly problematic and the Naim app gets blamed for lots of discovery issues that aren’t actually what is wrong. Mostly these are reported as solved when people switch to using ethernet.


1 Like

Yep completely agree, and having a satellite access point is a nifty solution if you can’t cable to the hifi