Firmware 3.8.3 - problems installing


Trying to update the firmware on the Atom to 3.8.3 but failing. It starts to download but the dowmload never completes. It reach about 80 % and then hangs and refuses to start the installation of the firmware update. Anyone else suffer the same issue and does anyone have any solution? Is it possible to download the firmware to a USB stick and then update the firmware that way?

The update must be done over the air. Have you tried pulling the plug on the Atom, leaving it for a few minutes and then restarting, before trying the update. If that doesn’t work, do a factory reset and try again. This will lose any settings, so try the unplugging first.

This version - for Atom only and for users of late 2022 models specifically, was released a year ago.
Any reason why you are only just updating?
There is a thread which may be worth a read Atom Firmware Update 3.8.3 - also worth doing a search of forum before just updating, since this update may not have even been necessary for your unit, ymmv.

Thanks all for your replies. Yes, i had read the other threads but wasn’t too keen to do a factory reset. However, in the end I had no other option then to do a factory reset and that did the trick. Problem solved.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.