Firmware Update to 1st gen MuSo(QB) not being downloded/installed

I’m trying to update the firmware for my st gen MuSo and MuSo QB and it’s looking for new firmwares, but not loading any. I’ve gone through the following:

use one wifi connection directly connected to internet (no firewall or similar), using an iPAD with the newest firmware and Naim App 6.01.

use wired network connection, DHCP
use wired network connection, fixed IPs.

restarted the devices by disconnecting them from the power for 10min

restarted the devices following a factory reset and followed by disconnect them from the power for 10min

None of the aforementioned solutions work! The App itself works flawlessly, is able to connect to all three devices (NAC-N272, Mu-So and Mu-So QB) and create a multi-room without issue.

The firmware on both the MuSo is 1.8 and it’s causing me not to be properly use Tidal.

I need a solution. Preferably one with a manual update (PC or similar, like the NAC-N 272)

Is the app telling you an update is available? I’m surprised this hasnt notified you before, firmware 2.0 came out September 2021.

You’ll need to speak to Naim tech support, I believe there’s an option to update via other means, they’ll share the file with you via dropbox.

I had opened a ticket with support and as you mentioned, they provided for two files (one for each device) by dropbox. Upgrading using these two files worked like a charm and went smooth without any hick-ups or issues. So, both are working perfectly with the new firmware.

Problem solved :slight_smile:

That’s good, glad it’s sorted. It was possibly an issue with how the upgrade is being delivered “ota”, and probably needs multiple service providers to reach all the mu-sos all over the globe.