Flash Remote Not Working

In 2009, I purchased a pre-owned CDS2. It came with a Naim Audio Flash remote control, which showed signs of fairly extensive use. Shortly after acquiring the CDS2, I managed to source a brand-new and unused Flash remote, although I retained an older Naim Audio remote control handset, which is the basic non-illuminated plastic type. I rarely use either remote control. At my age, the exercise provided by getting up from my chair is probably beneficial to my health! I noticed that the batteries in both remote control handsets had expired and decided to replace them. For the basic handset, this was a very straightforward operation and everything now works as it should. Replacing the batteries in the Flash handset has always been a delicate and tricky process. I eventually managed to get the new batteries fitted but found that the unit was no longer working. There was no illuminated display when the handset was picked up and the buttons do not function as they should. Prior to installing the new batteries, I removed the old ones and waited for a couple of hours before inserting new ones, as advised in the owner’s manual provided with the unit. I wonder if anyone has experience of using this handset and changing the batteries. Given the challenge of replacing the batteries and its subsequent failure to work, I suspect that the Naim Audio Flash is something that should not have been allowed to escape from the factory! Having said that, it is nice to use when it decides to work and I might consider returning it to the factory for repair. I should be grateful if someone from the factory could advise whether or not repair remains an option and could indicate a likely course. Thank you

PS The old one is still working, although the display has dimmed over the years.

Some advice here. Basically repeat the process if remote hangs or appears dead.

Flash battery replacement

I shall be interested to see the answer, and thrilled if it is positive.

I have a Flash which stopped working a couple of years ago, and I have always hoped that Naim could fix it for me, but events have intervened to prevent me from finding out.

(Naim stopped making the unit a few years ago because it contained something ‘bad’ which had been prohibited by the ‘elfin safety’ brigade - I can’t remember what. But the Flash is a lovely piece of industrial design, and I’d love to get mine operational again.)

You need to get the first three batteries in then be careful with the final one. Make sure you snap it quickly and cleanly into place. Otherwise it can partially charge the capacitor and it hangs the remote. You then need to wait until the cap discharges before trying again*.

*There is a short and dirty way of speeding this up by shorting out the cap, but I wouldn’t recommend this unless you are very sure what you’re doing.

1 Like

Thanks for the replies gentlemen. I will try repeating the battery change process in my newer Flash. One must however, observe that the potential challenge that one faces when replacing batteries in such an expensive remote remote control is attributable to poor original design by Naim Audio. As I previously observed, it shouldn’t have been released with such a significant drawback. Perhaps that’s why it was fairly quickly withdrawn from sale.

With a bit of plastic cut from a yogurt carton insert it so when its swiftly removed the contacts on the batteries will be live. If all is well you have a Flash which will keep going.
I think eventually it may die on you unfortunatly.
My understanding is the unit could be repaired at one time by Naim. However the EU? decided the toxic contents would not allow this. I am on my second one. The problem was not created by Naim but the rules changed part way through.
Hand it to a guest and they are likely to drop it because of the weight!

Thanks Douglas. I presume that I have read this correctly. Insert three batteries and then insert the bit of plastic before installing the fourth and final battery. When all batteries are in place, remove the plastic quickly. Is this correct?

That is indeed what he means. Often things that are shipped with batteries installed use such a device to allow the customer to activate the batteries without having to dismantle anything.

I was so frustrated with not being able to get the Flash to work over two days and not knowing the delay method I put the batteries in the wrong way round. There was a pop and smoke and then it worked perfectly after putting the batteries in the right way round. Presumably I had used the not recommended shorting method that Richard D mentions.

Hi JazzMan,
Thats what I did and it worked for me. Apparantly the insertion of the last battery without any temporary insulation is likely to make an intermittent connection and Flash does not like this.
Unfortunatly one of Naim’s most desirable products is just not repairable.

The Flash divides opinion but I have always really liked it. I have been lucky when changing batteries as it always worked seamlessly. 20 years old and going strong, but a future role as a paperweight awaits it’s eventual demise…